- User Since
- Jan 3 2017, 11:01 AM (75 w, 6 d)
Sat, Jun 2
Wed, May 30
I think you forgot to specify reviewers, so I added them for you.
Mon, May 21
Thanks @lueck for pointing these applications out; I have now re-added them to my active list.
Sun, May 20
I must admit that I just realized that the list of apps you can report a bug against is not the same as the ones accessible through clicking "Browse"...
But I think we should consider hiding the obsolete products not only when reporting bugs, but also in a) the advanced search & b) in the list from Browse. It'd simplify the search process for triagers a lot. Additionally, there are some products which are obsolete but you can still file bugs against them (e.g kaveau).
You forgot to specify any reviewers, so I added them for you. +1 from my side, removing code while improving the user experience is always a good thing :)
May 19 2018
I decided to do something remotely useful with my free time and sifted through all applications/libraries present on bugs.kde.org, removing most obsolete products. My guidelines to determine whether a product was deprecated were:
- Is the product not marked as "unmaintained"/"deprecated"/"replaced"?
- Is the product in the repositories of Ubuntu LTS?
- Is the product on cgit.kde.org?
- If it is on cgit.kde.org, does it have any activity in the last year?
Apr 28 2018
Yeah, pretty much ;) Nah, real life has been busy and I think that it'll take at least another two weeks until I can pick this up again. Frankly, I don't even really know what to implement now... Assuming that we do not want to WONTFIX the bug, we need to shrink the preview size down. @sharvey suggested that we set this to about 85% of the panel size, but this would not resolve the enormous icons if the panel is very wide. Should we introduce a cap (such as two times Size::Enormous)?
Apr 27 2018
Well, do we still need this code now? Are there any users which have not completed the transition yet? If yes, then we should try to find a way to still avoid these duplicates while preventing this crash.
Apr 22 2018
Apr 19 2018
+1 for asking institutions (especially in education). KDE has some great educational apps (GCompris, KStars, KGeography...) and there are even special distributions designed for schools (e.g. the "lernstick", a german project that is pretty much Debian with tons of edu-apps added in).
@ngraham Quick reminder: You can now mark this task as resolved as the 18.04 release happened today. Wohoo! ;)
Apr 11 2018
We can take some screenshots from your blog posts, but the question is how many screenshots are necessary/useful. I think that having three might be a good number, one for the "Empty Trash" button, one for the dockable Terminal plus either sorting by "Date Photographed" or the git integration. Thoughts?
Even though I wasn't able to reproduce the bug itself (probably because of some leftover old files), this patch is really needed as it'd be very bad if suddenly all places entries were displayed untranslated in 18.04. The patch itself seems reasonable (not a lot of changes -> not a lot to complain about), so +1 from me.
Apr 10 2018
Okay, so the functionality we are discussing is already implemented with D10246, but this patch suffers from the same problem. The patch does not apply cleanly for me, so I wasn't able to fiddle around with it. But theoretically, if we could resolve the remaining problem (Ctrl + F also closes the search box), we could simply use D10246 and the wish from bug 353227 would be fulfilled.
Apr 9 2018
Additionally, opening up a new tab could also cause more problems...
We would need to come up with a reliable way of detecting whether the search box is opened in a specific panel or not & update the state of the button respectively. I think we should still strive to implement this (even if this would be more complicated), as the feature itself is rather useful for the UX & we could also consider removing the [X] that currently looks a bit off.
Apr 3 2018
Apparently I misunderstood the goal of the task... Anyways, I guess I'll just wait until you made a decision (if the final result would be to change it, I'd do this if someone wants me to).
Hmm, I cannot really see the "other way" you are proposing... Do you want to simply change the F11 key, or not change anything at all (as we do not have a Full Screen feature right now)?
Apr 2 2018
I agree that the large icon might look too big for wide panels, but I guess the only really good way to optimize for such a corner case would be to increase the font size as well (which is another task, and might look bad).
Thinking about this for a bit, I tried to come up with a function keys setup which should be more consistent/make more sense (changed ones are marked in italics):
Apr 1 2018
Mar 31 2018
Clean up references to imageSize
Merge the ratingRole with widthRole/heightRole
Mar 30 2018
I am apparently not able to control arcanist... reverting changes which should have been in a different patch.
Mar 27 2018
Well, then we can simply keep the whole animation (as the animation only triggers if the size of the pixmap changes), adjusting it to only work if the panel is resized would probably require more code than the current solution.
Also adapt the size of all "Places" icons
Mar 25 2018
The hardcoded value is now removed.
Remove hardcoded value
Should be fixed on a higher level (translations) -> abandoning patch.
Mar 16 2018
This appears to be more complicated than I thought, thanks for the hint @fabiank . I think the best solution would be to notify the translators somehow, so that they can update the respective strings.
But I am not familiar with the translation process of KDE, so I don't know how to contact them... I guess I'll abandon this patch soon because it tries to fix a problem which should be resolved on a higher level.
US English, I guess the German translator already capitalized "Ordner" as this is the correct way in German.
Mar 15 2018
Mar 6 2018
Mar 4 2018
Abandoning because the behavior before the patch was the actually intended one.
Feb 17 2018
The way I am currently attempting to fix this bug is very inconsistent... I realized that it does not play well with the startup split view option.
Jan 23 2018
Change name from "Original Date" to "Date Photographed"
Dec 2 2017
Forgot to commit changes before generating the diff...
Dec 1 2017
Removed emptySearch variable, moved "Empty Search" to inline function.
Nov 23 2017
Window title is now "Empty search" when the user hasn't input any search term.
Nov 13 2017
Nov 12 2017
Removed the facetType() and currentFacet() function as proposed by @elvisangelaccio. Merged the search and text variable into searchText, which now uses %1 to add in the current search text for better localization. But I am not entirely sure if the consent is that we remove the facets from the title (which gives more space) or if I should keep it (which gives more information to the user) but adapt to the other comments.
@elvisangelaccio The basic patch is the same, but the "Places" feature has been added & some code style changes were made.
Hmm, I tested it multiple times (also with a completely fresh copy & applying the patch) and it always worked for me.
I am not very experienced with git and arc , but I think that everything should work now. Sorry for all the trouble with this patch.
Nov 11 2017
Weird, when I do
arc patch D8273
on the lastest master, the patch applies perfectly fine for me.
Nov 10 2017
This revision adds the feature proposed by @ngraham. The search text will now change to "Search for [type] named [input]" or "Search for [type]" if the user did not input a search term.
Nov 7 2017
- Changed "Searching [user input]" to "Search for [user input]"
- Instead of using isSearchModeEnabled() I now use viewPropertyContext(), although I am not 100% sure if that will work with all corner cases (@emmanuelp probably knows that better)
Oct 28 2017
Oct 15 2017
@emmanuelp Am I correct if I assume that I can then delete the changes made in dolphinviewcontainer.cpp/.h as the currentSearchText() function would then no longer be needed?
Oct 14 2017
Split the "caption" variable into two variables (schemePrefix & fileName) to reflect changes made from master since I sent this to review for the first time.