- User Since
- Apr 19 2015, 12:29 AM (182 w, 2 d)
Unless someone disagrees i'll commit this tomorrow
This looks reasonable to me, but since Luigi is the one that did most of the last work i'll let him do the actual approval for the patch :)
Yep, this looks more like it :)
I feel like having two classes of each is not the best of the ideas, since it seems the only difference in one you use 10 and in the other 100 in notifyValueChanged.
Have you asked sysadmin if by any chance they have a backup from that old site?
Sun, Oct 14
I still maintain this is wrong, and that there is no need for the second i18ncp since we don't support anywhere else different plurals for decimal numbers so we shouldn't here either, and as far as I know we don't support differnt plurals because all languages just use the same form for decimal numbers.
That's almost good, but the flag name should be more general, think like for example you would remove the manage bool and convert it to a flag too, so that if it the future someone needs to add a new flag, they can add it to that enum and don't need a new parameter.
Sat, Oct 13
*personally* I'd hate it to be the default, since clearing all the open files to get an empty one where i can write is something i do several times a day.
Fri, Oct 12
Oh you're doing this manually?
You fixed one and broke the other :D
Opening an image (Via File->Open) doesn't work (which i realize in the non ported version doesn't work either, but the error is different so you may want to have a look anyway.
With the new code i get 0,10 increments in Hue instead 0,03 but still far away from the 1,08 i get with the old version
Thu, Oct 11
I'm unconvinced whether this is actually better, but it's somehow similar to what poppler does, so maybe it makes sense?
It's just that, create a folder named autotest and put the tests there :D
@broulik so you were getting the
./kioslave/kamera.cpp:796: error(KIO::ERR_SLAVE_DEFINED, i18n("Could not read. Reason: %1",
often? Or is it somehow an inherited i18n call?
Adding new parameters is unfortunately Binary Incompatible so this can't go in this way, for it to work you'd need to add a new function with all the parameters and then call one from the other.
Wed, Oct 10
Add an autotests folder?
Tue, Oct 9
If you can fix this correctly once in KConfigDialog instead of adding bad magic numbers everywhere, fixing it in KConfigDialog seems to be a no brainer (maybe with an flag option to not change behaviour for people that don't want that)
Mon, Oct 8
I'm not thrilled about all these dynamic_cast< UnarFlavour * > in the ifs.
ah my fault was based on the other revision
629 is a random number, random numbers are bad.
Sun, Oct 7
Fri, Oct 5
Thu, Oct 4
Tue, Oct 2
I haven't tested it, but code seems sensible, so if you have tested it and are confident it works, i'd say go for it
Mon, Oct 1
This doesn't make sense to me, this code should not be triggered in the case that is higlighted in this bug since AutoFit in that very long document should never be a case of "the scrollbar vs no scrollbar fight", so what we need to figure out is why the if is being triggered and protect against it, not fixing what is inside the if.
Thu, Sep 27
Have you double checked with the civicrm consultant (forgot his name), that this is OK? Last i remember there was some incompatibility between the sepa stuff and the new civicrm versions.
Tue, Sep 25
Mon, Sep 24
The patch doesn't seem to apply here, is this on top of master?
Sun, Sep 23
The ported dialog looks bad, both because the layout of the new widget is not where you would want it to be and because it has much less functionality than the native dialog.
I don't like qrc, are you saying that the only way kxmlgui works on MacOs is by not installing files?
Sat, Sep 22
So there's unar and lsar? What's the difference? Can you add some more text to the summary explaining it?
Fri, Sep 21
Cool looks defenitely easier to understand, please remove the unneded include and commit :)