- User Since
- Apr 21 2016, 2:20 PM (177 w, 6 d)
Or let's just get it in. It's a small change and we still have the beta phase to test it.
Ok, you need this for 5.17?
Thanks for the patch Jason. So the GSendStr(nullptr) is called on m_password.isNull() because this aborts the current PAM session? If this is correct, patch looks good to me.
env var should be called KWIN_DRM_DEVICE_NODE
I'm ok with having this as a short-term fix but long-term this env var should go away again and be replaced with a better selection mechanism. So no guarantee that it will be available after 5.18 LTS.
Please more verbose summary.
I agree with Meta instead of Alt for all "system shortcuts". Hence I would like to see this as well for all window manager operations. Meta => system, Ctrl, Alt => applications.
Please next time besides a title add a meaningful description if you push a patch with more than a trivial change and without review. I assume it was just a mistake that you also didn't link back to the review in the commit bccbb8f3a5f8.
Mon, Sep 16
Reducing the screen area height makes it difficult to place outputs on top of each other. Making it a bit smaller is fine (and improving the logic of how much this it in comparison to overall kcm size) but I think this is too much. Alternatively the size of the outputs could be reduced.
Do we need KKeyServer at all on Wayland?
@zzag You improved the scripting on Wayland, right? Is this task resolved?
@zzag What's your opinion on that? Is this only relevant for Wayland?
Would this really be so helpful?
See also D7524.
Have not noticed this problem for ages. Above bugs seem to be closed fixed or not reproducible with latest Qt build.
Don't understand what the goal of this task is or how it is supposed to work. Closing as invalid because of that. I somebody can explain pls leave a comment and reopen.
What test clients there are?
What test clients there are?
@zzag is this task still pending? Can you add some more detail to the description what it is about?
Forcing linear filter as in D23986 looks to be enough for down-scaling. Mipmaps could still make sense for improving the quality of down-scaling further. For upscaling Lanczos filter could make sense but in perfect conditions there is no upscaling needed on Wayland.
Replaced by D23986 with only the filter change but without trying to generate mipmaps. Keeping this in diff separated for reference.
Is this still relevant? Is the Font installation KCM the same as the Fonts KCM? Fonts KCM doesn't crash for me.
Not completely sure about the task description but if I understand it correctly they already do that.
From other task:
This is an outdated task. The plan is at the moment to remove Screens global.
Sun, Sep 15
This discussion once again consumes everyone's precious time on a minimal change. It needs to come to a conclusion.
Sat, Sep 14
This link should have been in here long ago for reference.
Where's the best place to get in contact to get this moving (when I have time to)?
The principle is not in question here. The Outputs child class provides a conversion of QVector used for output-alike classes through constructor-override. It's an implementation detail and to be honest it's a non-issue, not worth our time.
As already discussed in the other diff I don't want to guess all the time what private fields get manipulated by the backend somewhere. If you want to improve the code make it unnecessary that DrmBackend is friend with DrmOutput, not do it for all the other backends alike.
Title of this diff must be changed before push.
You need to provide sources for such generic statements. If you would be a computer science professor of 30 years I would believe them without asking for such but we are not.
Fri, Sep 13
I don't care either way. @davidedmundson came up with the Output as child of QVector construct. So it's important what he thinks.
Is this just a code cleanup or also logic change? There is a TODO in there. Overall difficult to review without more explanation.