- User Since
- Apr 14 2015, 9:17 PM (267 w, 1 d)
Wed, May 20
Tue, May 19
Mon, May 18
Sun, May 17
Tue, May 12
Done. Thanks again for the patch!
Mon, May 11
Superseeded by https://phabricator.kde.org/D29548 since there was no activity for >2 months.
Sat, May 9
Mon, May 4
Sun, May 3
Apr 24 2020
A model like this could be quite useful I think.
Apr 23 2020
And I'l just be using my keyboard shortcut ;)
I'm not fond of this change, but I agree with Nate's comment about the possibility of setting 'always visible' for users that wish to keep the current behaviour, so I'm not going to give this a -1.
Not sure I like pulling in Kirigami just for this. Are there other places where Kirigami could improve the Vaults applet?
Apr 21 2020
Apr 17 2020
Apr 13 2020
Maybe "Unable to close the vault; it is being used by %1" -> "Unable to close the vault as it is being used by %1" ?
Apr 3 2020
Any news on this?
Mar 19 2020
used Layouts instead of Anchors
Last change - use "activities" icon if no icon is set (though this should not happen if the user creates the activity through legal ways)
Kirigami has quite interesting features I must say :)
The reason for the icon setting is to have full backwards compatibility. Maybe someone likes the static icon better than random icons they set for each activity. I don't like to have everything configurable, but here it is not a significant maintainance overhead, and the configuration dialogue would be quite dull with a single checkbox :)
Mar 17 2020
Of course... I need to reboot my brain it seems.
Mar 16 2020
Mar 15 2020
I assume people tell you that you're awesome all the time, so I'm not going to ;)
I like it. Is the device notifier going to look like this as Vaaults tried to mimic that one?
Feb 26 2020
This looks cool. The thing I'm missing (correct me if I'm wrong - I'm yet to test the patch) is for it to open the switcher when dragging the window over the switcher applet icon.
Feb 16 2020
Cool idea, I'll have to think of something similar for the regular activity switcher
Jan 20 2020
Jan 7 2020
That is why I put the "or in addition to" part.
Jan 6 2020
Why not change the recentdocuments runner?
I hate Qt... defining operator* without operator-> ... ugh
Yes, the wrapper just serves for keyval iterators to be usable with a range-based for loop. Quite useful if there are a lot of these. In this case, where it is only one loop I agree it might be an overkill.
Something like this:
TBH, I'd like more to have dirs always end with a slash, but I guess this is fine as well.
For some reason, hiding this icon when there are no vaults was deemed undesired before. I don't recall why as I think it is a good idea. :)
Nov 3 2019
Oct 17 2019
Just add TODO and you are free to push