- User Since
- Jan 25 2016, 10:25 AM (138 w, 6 d)
Wed, Sep 19
Wed, Sep 5
I'm not really capable of doing an in-depth review here, since I don't know enough details of PHP nowadays. Style-wise I think it could still profit from reducing the block size of un-named (i.e. not a function with a name), uncommented complex code a bit, since it often requires quite some thinking to grasp what a certain conditional actually checks for. A simple comment like "// not a function" or whatever can do wonders there.
Feel free to merge this as-is or with a bit more comments, better get it in before the beta and still have a fix window before the release than merge it after the beta. Thanks for keeping kdev-php alive!
I'm super confused by the diff phabricator shows below but the commited changes are correct (and different from the diff here) ... what's going on?
For the record, I tried writing a test for this but didn't succeed and eventually put it aside, although the difference is easily visible in a test application. There must be a reason why the naive test case behaves differently from an interactive application ... I could take another look, I guess.
Aug 21 2018
Aug 20 2018
Aug 19 2018
Aug 17 2018
Sorry, never mind -- that code I removed yesterday. All should be fine.
Looks ok to me, except one thing: the operator== is used to compare a note from the list to the "currently active" note in the view. If this compares also the "under mouse" state, this code might be broken now ...?
Good amount of tests :) For the actual implementation, I would suggest trying to make it a bit more readable by a) splitting it up into several functions and b) trying to reduce indent depth a bit by using continue instead of nested ifs.
Maybe you make the the visitAssignment code a bit more readable by breaking it up into 2-3 functions?
As I said at Akademy already, I am neither familiar with the code of the PHP plugin nor with the later developments in the language itself, so I'm not a good reviewer for these patches. But since you want to get them in and nobody else seems to have time, I have read through this and I can't spot anything obviously wrong or stupid. We'll have a beta to try it out :)
Thanks for the patch, the approach looks reasonable at a first glance. You might want to unite the up/down functions ...
It is too much of a WiP to merge it like this, though.
Aug 16 2018
Author: Sven Brauch <firstname.lastname@example.org>
Date: Tue Aug 14 12:31:31 2018 +0200
update license text
Implement Dominik's suggestions
The patches you submitted recently are all very nice, if you feel think you are going to contribute more things in the future, I'm sure we can give you the permission bit to write to the KDE repos yourself :)
Just let us know at any time if you want that.
Of course arc is too stupid for the special characters in your name, sorry about that ...
No, you need special karma to push to the KDE repos. If you are not aware you have this, you have not ;)
I will submit this for you later.
This change looks very reasonable to me. Thank you!
Aug 15 2018
I'm actually fine with this approach, I just don't understand why the environment is set once on the process and once on the job. Why is this necessary, or do I misunderstand what it's doing ...?
address Dominik's suggestion and split focus handling and click handling
I have infinite patience in watching other people do the work, so by all means, go ahead! :-)
Thanks for the patch!
I added the rest of the interaction interface (click, mouseover)
and reduced the API a bit by moving a few hints into the InlineNote
Aug 14 2018
Can't we simply update our shipped schemas, and expect users with custom schemas to fix them?
Somehow I find the code rather strange, with the destructor removing items from the item model ...
But ok, if you tried it out and it fixes the problem, I guess it's fine.
add noteActivated notifier function
Looks good to me, even with unit test! :)
If nobody objects within the next few days, I'll merge this.
Thanks for the feedback! I will try doing a few more things with this interace and then maybe discuss again with the other kate people here at Akademy about which one they like better.
add missing files
Sample patch for KDevelop's problem highlighter plus screenshot:
Aug 13 2018
Ok, fine with me, I don't care much about the type. I just stumbled upon the comment and then noticed the type as well. Thanks for the patch, all fine from my side :)
Submitted with f30ef7c6f1376 to 5.2, sorry, I forgot to set the diff in the commit message.
Good find, the previous code (remove item -> call beginRemoveRows() -> call endRemoveRows()) definitely looks wrong. Can you submit this yourself?
Otherwise, I'd need an email address to set as the commit author.
Now I would compute the fileInfo's canonicalPath only once (it might require a stat) and then this looks okay :)
I can't accept it apparently because the discussion is still open ...
Yes, that looks reasonable.
I'd like to play with this a bit wrt what can be done in KDevelop with it (I want the problem popups gone). Would you mind if I do some changes along the way? I would post an updated patch here, in case I actually come up with useful changes ...
By the way, other people around here are very impressed by this patch as well, and we'd really like to get this merged :)
Moving e.g. KDevelop's warning markers into an inline note instead of the annoying popup would make a real difference for usability ...
Wow, that looks amazing! Really impressive.
Aug 12 2018
The "overly sensitive touchpad" issue seems to be missing accumulation of scroll events, so this patch to my understanding should not have it.
I will modify the commit message as suggested.
Ok, I'll submit it later today then.
This looks good to me, feel free to submit it (can you?). Thanks!
Yes, that makes sense to me.
Hey there, what's happening to this? I think this is a really nice feature and it would be very sad if it would bitrot :(
Anything anyone can assist with? We are currently at Akademy, KDE's annual conference, so we would have time to discuss any issues right now.
Aug 6 2018
We should try to figure out what code leads to creating a function declaration with no function type assigned, but this check makes sense in any case. Thank you!
Jul 27 2018
That said, I can understand your mood (I've felt the same before with things I submitted somewhere, I think everyone has) and I'm sorry for it. But I agree with Kore that we should try to merge patches based on what objectively makes things better.
Just install perf and hotspot, then compile in "RelWithDebInfo" mode and run
Jun 23 2018
Looks reasonable to me. Can you submit the patch yourself or should I do it?
No, this looks good to me. Thanks!
Of course, nobody is exactly sitting here thinking "eeh, now I've been waiting for that guy for *weeks* to get his patch in" ;)
If you need advice, feel free to ask.
Jun 21 2018
No, I think you should introduce a way to get the session name before the colon is added. You can introduce a new role for the item model for example, have a look at QStandardItem::setData.
Try opening a few projects in the session. The names of these projects should follow the colon afterwards.
AFAIK that is followed by the names of the projects open in that session, and that is also where your approach with chopping of the chars will probably go wrong.
KDE only uses github as a read-only mirror. You will get a notification when it is submitted.
Otherwise looks good, I can submit this later.