Unify how we refer to KRunner
Closed, ResolvedPublic


In some places, KRunner is referred to as "Run Command" which is inaccurate because that's only one of its many functions, and it's a verb-based action string which in some contexts is misleading (e.g. in the KWin Touch Screen KCM's action chooser, where the user naturally asks "how do I choose which command it will run?").

In other places it's referred to as "Plasma Search" or "Search Bar" which is also only one of its many functions, and introduces even more inconsistency, impeding users' ability to know these are all the same thing.

All of these terms also suffer from being generic-sounding, and they help neither expert users who know it as KRunner, nor novice users who do not gain accurate information about what it is by having it referred to using inconsistent, inaccurate, and generic terminology.

I propose that we embrace KRunner's real name and use it (e.g. "Show KRunner", "Configure KRunner", etc), and then consistently use this terminology everywhere. Basically we make KRunner a brand like Apple did with their similar Spotlight tool.