Thanks, this generally works very nicely. I found a big bug though: when you rename a tab and then move it to another position on the tab bar, the tab in its old position no longer updates its name when the user navigates around in that tab, and the renamed tab inappropriately does update its name as the user navigates around.
Spaces around the equals sign
"Rename Tab" (use title case for window titles)
Don't want this in production code
Unnecessary whitespace change
I've updated the diff, fixing both the issue with tab movement and styling.
I don't know if it would be a good idea to add a parameter (--tabname or something) to main.cpp to allow passing the tab name after detachement. What do you think?
Unused, please remove it.
We could use a more descriptive variable name here, for example renamed or similar.
Please add const
Maybe we can add a colon at the end of "New tab name" ?
Coding style: please call it uuid(), we don't usually use the getXXX naming style for getters.
Not needed, the constructor is implicitly called for QMap objects.
Coding style: brace should go to next line for functions.
Coding style: else starts at the end of previous line.
Maybe this logic should be moved to the tabName function instead?
Why is this information stored here and not in the individual Tab Pages? If a Tab Page knew it's own name, you wouldn't need the UUID stuff so it could simplify the code quite a bit.