Tools: Sync with TelepathyQt (make compatible with Python 3)
ClosedPublic

Authored by akulichalexandr on Sep 18 2019, 10:15 PM.

Details

Test Plan

Do a clear build without Python 2 in the build environment.

Diff Detail

Repository
R476 Telepathy Logger Qt bindings
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
akulichalexandr requested review of this revision.Sep 18 2019, 10:15 PM
akulichalexandr created this revision.

I don't know much about python, but it works fine with python3 where it previously didn't. +1

xincludator.py: Change output format to UTF-8 (fix LANG=C)

In fact, Telepathy specs has special symbols (e.g. copyright sign), so it is
not correct to save XML in ASCII.

This revision was not accepted when it landed; it landed in state Needs Review.Oct 3 2019, 8:30 PM
This revision was automatically updated to reflect the committed changes.
wbauer added a subscriber: wbauer.Jan 15 2020, 10:25 AM

Maybe it would be good to make a new release as well, now that Python2 is EOL...

Maybe it would be good to make a new release as well, now that Python2 is EOL...

I prepared one, if you want to test before it goes public:
https://dev.exherbo.org/~heirecka/telepathy-logger-qt-17.09.0.tar.xz
https://dev.exherbo.org/~heirecka/telepathy-logger-qt-17.09.0.tar.xz.sig

wbauer added a comment.EditedFri, Mar 13, 9:45 PM

Maybe it would be good to make a new release as well, now that Python2 is EOL...

I prepared one, if you want to test before it goes public:
https://dev.exherbo.org/~heirecka/telepathy-logger-qt-17.09.0.tar.xz
https://dev.exherbo.org/~heirecka/telepathy-logger-qt-17.09.0.tar.xz.sig

Yes, it builds fine here on several openSUSE versions with python3 only, thank you.
(which is not surprising, as we already use this patch since January anyway)