The prior error was misleading, and always said "Disk full." even when the disk wasn't actually full; not having enough space to move or copy the requested file doesn't mean that the disk is full! This patch re-words the error message to be clearer and still work when errorString is defined (as it always should be).
Details
- Reviewers
shubham - Group Reviewers
Frameworks VDG Dolphin - Commits
- R241:78c4f3496671: Improve "insufficient disk space" error message
Before:
After:
Diff Detail
- Repository
- R241 KIO
- Branch
- improve-insufficient-disk-space-error-message (branched from master)
- Lint
No Linters Available - Unit
No Unit Test Coverage - Build Status
Buildable 2931 Build 2949: arc lint + arc unit
I like the proposal already. I would just add other strings for perspective:
- Cannot move file. File larger than remaining space.
- Unable to move file, insufficient space remaining.
We can't use the words "file" or "move" since this part of the code can't know whether the user is moving or copying, or whether the thing being moved or copied is a file or a directory. Adjusting the code here to know those pieces of information not easily possible and would involve patches to multiple other repos--and it's also out of scope for this patch. :)
Not married to any string. I think the patch is already improving it, just showing some perspective. I guess my main angle is to communicate the information as soon as the sentence starts. Something like "Not enough" or "Unable to" right off the bat so it can have a more immediate understanding from the user. ;)