Remove old code that is not used anymore
ClosedPublic

Authored by davidre on Mon, Jan 27, 5:35 PM.

Details

Summary

According to the comment it was for Qt3 support which we don't support anymore.

Diff Detail

Repository
R265 KConfigWidgets
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
davidre created this revision.Mon, Jan 27, 5:35 PM
Restricted Application added a project: Frameworks. · View Herald TranscriptMon, Jan 27, 5:35 PM
Restricted Application added a subscriber: kde-frameworks-devel. · View Herald Transcript
davidre requested review of this revision.Mon, Jan 27, 5:35 PM

Does it affect:

kwidgetsaddons/src/kselector.h:48

(no idea what that is, just something grep found)

If it's still something we ship than I think it is better to just change the comment

ervin added a comment.Tue, Jan 28, 6:20 PM

LGTM, better wait for @dfaure opinion though

dfaure requested changes to this revision.Sun, Feb 2, 10:51 AM

I don't really know KConfigDialogManager. But indeed KSelector has properties with those names so if someone wanted to use e.g. KGradientSelector here it sounds like this would be useful -> just adjust the comment?

This revision now requires changes to proceed.Sun, Feb 2, 10:51 AM
davidre updated this revision to Diff 74856.Sun, Feb 2, 1:46 PM

Update comment

dfaure accepted this revision.Sun, Feb 2, 1:56 PM
This revision is now accepted and ready to land.Sun, Feb 2, 1:56 PM
This revision was automatically updated to reflect the committed changes.

I just took a look at KSelector and it actually inherits minimum and maximum properties from QAbstractSlider so we could just drop these custom properties for KF6