Brings us one step to closer to not needing to create lists of source files
- Group Reviewers
Frameworks Build System
- R237:215986603c0f: Allow to also pass a target instead of list of sources to KCONFIG_ADD_KCFG_FILES
While touching this file, you might want to fix this file and make it self-contained by also having a include(CMakeParseArguments) at the begin, could be done as direct commit, no review needed IMHO :)
No comment on the actual new method API, I yet have to get used to the idea of direct target handling like target_sources, so lacking sense if the proposal is good.
I propose to rename _sources to _target_or_source_var to make the code less surprising.