Replace usage of deprecated SlaveBase::config() by SlaveBase::configValue
ClosedPublic

Authored by meven on Wed, Oct 16, 7:48 AM.

Details

Summary

With D23523 and D24582, we can avoid some IO by not using SlaveBase::config()

Will wait for KF 5.64 release before landing.

Test Plan

Compiles

Diff Detail

Repository
R320 KIO Extras
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
meven created this revision.Wed, Oct 16, 7:48 AM
Restricted Application added projects: Dolphin, Frameworks. · View Herald TranscriptWed, Oct 16, 7:48 AM
Restricted Application added subscribers: kfm-devel, kde-frameworks-devel. · View Herald Transcript
meven requested review of this revision.Wed, Oct 16, 7:48 AM
dfaure accepted this revision.Sun, Oct 20, 10:36 AM

I never know when it's OK to increase the KF5 version dependency from applications modules, though.

I have a ton of pending patches (to port away from KWindowSystem deprecated API) which require a KF5 version dep upgrade too...

This revision is now accepted and ready to land.Sun, Oct 20, 10:36 AM

I never know when it's OK to increase the KF5 version dependency from applications modules, though.

I have a ton of pending patches (to port away from KWindowSystem deprecated API) which require a KF5 version dep upgrade too...

It's always ok to bump the KF5 version as long as you do it before the dependency freeze day set by the release team.

Thanks for the information.

https://community.kde.org/Schedules doesn't have a 19.12 schedule so I guess there's no freeze yet :-)

meven added a comment.Mon, Oct 21, 7:33 AM

It's always ok to bump the KF5 version as long as you do it before the dependency freeze day set by the release team.

So I guess it is the case here : Apps 19.12 is still in a few months, we can bump KF5 deps I think.

This revision was automatically updated to reflect the committed changes.