[KWidgetAddons] port to non-deprecated Qt API
ClosedPublic

Authored by dfaure on Mon, Sep 9, 1:49 PM.

Details

Test Plan

Added "cxxflags -DQT_DISABLE_DEPRECATED_BEFORE=0x060000" to
kdesrc-build's kf5-frameworks-build-include (in the frameworks module-set)

Diff Detail

Repository
R236 KWidgetsAddons
Branch
master
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 16290
Build 16308: arc lint + arc unit
dfaure created this revision.Mon, Sep 9, 1:49 PM
Restricted Application added a project: Frameworks. · View Herald TranscriptMon, Sep 9, 1:49 PM
Restricted Application added a subscriber: kde-frameworks-devel. · View Herald Transcript
dfaure requested review of this revision.Mon, Sep 9, 1:49 PM
aacid added a subscriber: aacid.Mon, Sep 9, 1:54 PM

+1 looks sane but i have not tried this

src/kcollapsiblegroupbox.cpp
288

if you get bored, add const?

src/kpixmapregionselectordialog.cpp
53

same, if you get bored, const

cfeck added inline comments.Mon, Sep 9, 3:24 PM
src/kpopupframe.cpp
23–24

Please keep this sorted.

dhaumann added inline comments.
src/ktitlewidget.cpp
137

Is that not needed anymore?

Lgtm.

src/ktitlewidget.cpp
137

Sorry, the next line gives the answer ;)

dfaure updated this revision to Diff 65703.Mon, Sep 9, 8:51 PM

constify, sort includes

cfeck accepted this revision.Mon, Sep 9, 10:28 PM

Merci!

This revision is now accepted and ready to land.Mon, Sep 9, 10:28 PM
dfaure closed this revision.Tue, Sep 10, 8:03 AM