[Energy] Put battery capacity info in battery section and call it "Capacity degradation"
ClosedPublic

Authored by ngraham on Mon, Aug 19, 7:09 PM.

Details

Summary

Alternative to D22882.

Our use of "capacity" to refer to how much of a battery's original capacity remains is
confusing. This is made less confusing by inverting the number and referring to it as
"degradation". "Capacity degradation: 21%" communicates that the battery has lost
21% of its original capacity far better than "Capacity: 79%" does, because the latter
is easily confused with the battery's current charge level.

To further reduce the confusion, the battery's degradation level is relocated to end
of the Battery section.

Test Plan

Diff Detail

Repository
R102 KInfoCenter
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
ngraham created this revision.Mon, Aug 19, 7:09 PM
Restricted Application added a project: Plasma. · View Herald TranscriptMon, Aug 19, 7:09 PM
Restricted Application added a subscriber: plasma-devel. · View Herald Transcript
ngraham requested review of this revision.Mon, Aug 19, 7:09 PM
ngraham retitled this revision from [Energy] Use but battery capacity info in battery section and call it "degradation" to [Energy] Put battery capacity info in battery section and call it "degradation".Mon, Aug 19, 7:10 PM
meven added a comment.Tue, Aug 20, 5:56 AM

To further reduce the confusion, the battery's degradation lavel is relocated to the Battery section.

I don't think that is necessary.
What is confusing in a degradation value in an energy section ?
It is clearly an energy degradation value.
If we want to make things clearer we could name "Degradation" "Capactiy degradation" for instance or rename "Capacity" to "Battery capacity remaining" for that matter..

filipf accepted this revision.Tue, Aug 20, 8:22 AM
filipf added a subscriber: filipf.

Both changes make sense to me.

"Capacity" really is used elsewhere but I find it ambiguous as well; the same can't be said about "degradation" however.

The "Battery" section also makes more sense to me because it's a property of the battery.

This revision is now accepted and ready to land.Tue, Aug 20, 8:22 AM
meven added a comment.EditedTue, Aug 20, 8:37 AM

Well capacity or degradation are expressed in % which differentiates it from energy values and makes it more informative.
So in the end I agree degradation/capacity makes sense in the Battery section.

Two things though, I would add charge level below charging, I feel it is really missing, and move degradation at the end of the battery properties as it is the less important in this section.

"Rechargeable" property is quite questionable also, since how often do we have batteries on computers or peripherals that are not rechargeable ?

I don't like this change because it introduces a Plasma-specific formula and makes the user guess how to match "degradation: 21%" against let's say "capacity: 85%" s/he saw when using a different OS or desktop environment. For example:

  1. User looks at battery status in Plasma 5.16 and remembers battery capacity is 85%,
  2. User updates to Plasma 5.17 and now there is "degradation 21%". How does one know if battery health improved or worsened over time and if the change was substantial?

To further reduce the confusion, the battery's degradation lavel is relocated to the Battery section.

I don't think that is necessary.
What is confusing in a degradation value in an energy section ?
It is clearly an energy degradation value.

No, energy doesn't degrade, but a battery does. Degradation is a property of the physical battery itself, not its energy.

If we want to make things clearer we could name "Degradation" "Capacity degradation" for instance

That could work.

I don't like this change because it introduces a Plasma-specific formula and makes the user guess how to match "degradation: 21%" against let's say "capacity: 85%" s/he saw when using a different OS or desktop environment. For example:

  1. User looks at battery status in Plasma 5.16 and remembers battery capacity is 85%,
  2. User updates to Plasma 5.17 and now there is "degradation 21%". How does one know if battery health improved or worsened over time and if the change was substantial?

I think the more likely scenario is as follows:

  1. User looks at battery status in Plasma 5.16, sees "capacity" at 85%, and has no idea what this means, because it implies that the battery is 85% charged but this can't be the case as other stats conflict with this interpretation
  2. User updates to Plasma 5.17 and now there is "Degradation 21%". User now understands that this means their battery capacity is degraded. Maybe the string could be even further improved as "Capacity degredation:" as @meven suggested.

At least, that's how it was for me. I did not understand what "Capacity:" was referring to until I started browsing the code. "Capacity" is an ambiguous and non-descriptive term that does not really communicate the concept we're trying to get across.

At least, that's how it was for me. I did not understand what "Capacity:" was referring to until I started browsing the code. "Capacity" is an ambiguous and non-descriptive term that does not really communicate the concept we're trying to get across.

How about this: "Capacity: 79% (degraded by 21%)"?

Or keep the label as is and add a link "What's this?" that would show a popup with an in-depth description of battery capacity, degradation, why it happens and what to do about it.

At least, that's how it was for me. I did not understand what "Capacity:" was referring to until I started browsing the code. "Capacity" is an ambiguous and non-descriptive term that does not really communicate the concept we're trying to get across.

How about this: "Capacity: 79% (degraded by 21%)"?
Or keep the label as is and add a link "What's this?" that would show a popup with an in-depth description of battery capacity, degradation, why it happens and what to do about it.

Hmm, both suggestions seem to be designed to explain what "capacity" means rather than replacing it with something that doesn't need explanation at all. I don't really see the point of keeping the word "Capacity" visible when we can replace it with something that doesn't need additional explanation.

Also, I don't think QML stuff do "What's This?" text, and even if it could I wouldn't want to use it because the "What's This?" feature is poorly-discoverable and not a substitute for clarity in the user-visible strings.

If keeping the word "capacity" is a sticking point, I'd like to go with @meven's suggestion of "Capacity degredation". Would that be acceptable?

Hmm, both suggestions seem to be designed to explain what "capacity" means rather than replacing it with something that doesn't need explanation at all. I don't really see the point of keeping the word "Capacity" visible when we can replace it with something that doesn't need additional explanation.

Ok, let's go with "degradation: nn%" + a "what's this" link.

Also, I don't think QML stuff do "What's This?" text, and even if it could I wouldn't want to use it because the "What's This?" feature is poorly-discoverable and not a substitute for clarity in the user-visible strings.

I think you missed my point, the regular "what's this" tool is indeed poorly discoverable. Consider this type of "tooltip" for the KCM:


And for the plasmoid we may use an "i" icon instead to make it compact.

I think you missed my point, the regular "what's this" tool is indeed poorly discoverable. Consider this type of "tooltip" for the KCM:


And for the plasmoid we may use an "i" icon instead to make it compact.

Ah I see what you mean, thanks. However this isn't a UI that we use in other places and I don't think it it's even necessary. "Capacity degradation" is perfectly clear IMO. What more would we need to explain? Again I feel like if possible it's preferable to use a term that doesn't need explanation rather than going to great pains to provide an explanation via a secondary mechanism.

"Capacity degradation" is perfectly clear IMO.

You may be right, my opinion is biased.

ngraham updated this revision to Diff 64141.Tue, Aug 20, 5:37 PM

Rename to "Capacity degradation" for extra clarity, and move to the end of the Battery section

ngraham retitled this revision from [Energy] Put battery capacity info in battery section and call it "degradation" to [Energy] Put battery capacity info in battery section and call it "Capacity degradation".Tue, Aug 20, 5:38 PM
ngraham edited the summary of this revision. (Show Details)
ngraham edited the test plan for this revision. (Show Details)