Don't enable QT_STRICT_ITERATORS on Windows.
ClosedPublic

Authored by dfaure on Tue, May 21, 7:32 AM.

Details

Summary

Strict iterators can't be used on Windows, they lead to a link error
when application code iterates over a QVector<QPoint> for instance, unless
Qt itself was also built with strict iterators.
See example at https://bugreports.qt.io/browse/AUTOSUITE-946

Technically this would be fine for mingw, but not for MSVC neither
clang-cl (which also uses the MSVC ABI). I think it's fine to just
disable it for all Windows compilers, since any iterators misuse
will be detected on Unix anyway.

Test Plan

None, I'm relying on Volker's findings.

Diff Detail

Repository
R240 Extra CMake Modules
Branch
master
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 12008
Build 12026: arc lint + arc unit
dfaure created this revision.Tue, May 21, 7:32 AM
Restricted Application added projects: Frameworks, Build System. · View Herald TranscriptTue, May 21, 7:32 AM
Restricted Application added subscribers: kde-buildsystem, kde-frameworks-devel. · View Herald Transcript
dfaure requested review of this revision.Tue, May 21, 7:32 AM
dfaure updated this revision to Diff 58393.Tue, May 21, 7:32 AM

Remove unrelated change

dvratil accepted this revision.Tue, May 21, 2:09 PM
This revision is now accepted and ready to land.Tue, May 21, 2:09 PM
dfaure closed this revision.Wed, May 22, 7:49 AM