Updated minimal Qt version to the earliest supported version (5.9)
ClosedPublic

Authored by nmel on Apr 8 2019, 7:54 AM.

Details

Summary

Since there were no objections, updated Qt version.

Test Plan

cmake, compile and run

Diff Detail

Repository
R167 Krusader
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
nmel requested review of this revision.Apr 8 2019, 7:54 AM
nmel created this revision.

QOverload is only available in Qt >= 5.7, and Qt 5.9 is the earliest supported version.
See also https://bugs.kde.org/show_bug.cgi?id=405212 .
I proposed this change in the discussion of D19623 and there were no objections for a month.

yurchor accepted this revision as: yurchor.Apr 10 2019, 7:21 AM
This revision is now accepted and ready to land.Apr 10 2019, 7:21 AM
abika accepted this revision.Apr 13 2019, 4:40 PM

After rethinking this, I agree with you, Nikita. We should not impose the burden of supporting an outdated Qt version on ourself.

Please also close https://bugs.kde.org/show_bug.cgi?id=405212 when merging this.

This revision was automatically updated to reflect the committed changes.
nmel added a comment.Apr 15 2019, 6:51 AM

Thank you, Yuri and Alex!