Replace all usages QOverload with static_cast
AbandonedPublic

Authored by abika on Mar 8 2019, 7:18 PM.

Details

Reviewers
None
Group Reviewers
Krusader
Summary

QOverload is only available in Qt >= 5.7.

See https://bugs.kde.org/show_bug.cgi?id=405212 .

Test Plan

Krusader compiles.

Diff Detail

Repository
R167 Krusader
Branch
my-replace-qoverload
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 9349
Build 9367: arc lint + arc unit
abika requested review of this revision.Mar 8 2019, 7:18 PM
abika created this revision.
yurchor added a subscriber: yurchor.Mar 8 2019, 8:18 PM

What is the purpose of this change?

/krusader/Panel/panelfunc.cpp:520 contains

file.open(QIODevice::NewOnly);

and NewOnly is available since Qt 5.11. So the current git/master only compiles for Qt >= 5.11.

https://doc.qt.io/qt-5/qiodevice.html

Thanks in advance for your answer.

nmel added a subscriber: nmel.Mar 9 2019, 6:49 AM

Good point, Yuri. We should look into other cases as well.

IMO, QOverload looks cleaner. Why don't we raise minimal requirements to qt-5.7 or even qt-5.9 LTS, since <= qt-5.6 support will expire in a few days, and work around cases that don't compile with minimal version?

abika abandoned this revision.Sat, Apr 13, 4:32 PM

Discarded in favour of D20373.