Removed unncessary switch and replaced it with simple if, more efficient
I am with Kåre here: this change does not fix any issue nor does it improve the current state significantly. In fact, there is a risk of introducing a regression by removing the accept/reject calls.
I don't think this should go in as is.
Shubham, on bugs.kde.org we have more than 300 open bugs. Maybe you can find something there? Would be really nice :)