Updated old style casts in some files
please remove the mention of changes different than old style casts in the commit message
this change is OK, but please create a separate commit for it
floor() does not have a "int" variant, so forcing the type of its argument to double helps the compiler to choose the right variant
Seems like I messed up again in this review (I'm really sorry again). I'm at Lakademy and I asked for help to fix the mess i've made, as soon as the review is fixed I'll let you know.
Sorry again :(