KReport Big Rename
ClosedPublic

Authored by piggz on Sep 28 2015, 9:47 PM.

Details

Summary

Renamed all files/classes to CamelCase with KReport prefix
(except some internal and classes in plugins still to do)

Test Plan

ran auto tests and example app

Diff Detail

Repository
R14 KReport
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
There are a very large number of changes, so older changes are hidden. Show Older Changes
staniek added inline comments.Oct 11 2015, 8:35 PM
src/common/KReportPageOptions.h
41

BTW, make all get* methods const.

61

BTW, -> const

66

-> QString getLabelType() const

src/items/check/KReportCheckBoxPlugin.h
27

-> KReportCheckBoxPlugin

src/items/check/KReportDesignerItemCheckBox.h
30

-> KReportDesignerItemCheckBox

src/items/check/KReportItemCheck.h
32

-> KReportItemCheckBox

src/items/check/KReportScriptCheck.h
28

-> CheckBox

src/items/field/KReportFieldPlugin.cpp
2

It seems to be marked as deleted instead of 'moved'.

src/items/image/KReportDesignerItemImage.h
27

-> KReportDesignerItemBarcode

src/items/image/KReportImagePlugin.cpp
2

It shows as a new file, not a rename...

src/plugins/barcode/KReportBarcodePlugin.h
25

-> KReportBarcodePlugin

src/plugins/barcode/KReportItemBarcode.h
34

-> KReportItemBarcode

src/plugins/chart/KReportChartPlugin.h
25

KReportChartPlugin

src/plugins/chart/KReportItemChart.h
35

-> KReportItemChart
BTW:
KoReportDesignerItemChart -> KReportDesignerItemChart

src/plugins/maps/KReportItemMaps.h
44

-> KReportItemMaps

src/plugins/maps/KReportMapRenderer.cpp
31

-> KReportMapsRenderer

src/plugins/maps/KReportMapsPlugin.h
26

-> KReportMapsPlugin

src/plugins/web/KReportItemWeb.h
42

-> KReportItemWeb

src/plugins/web/KReportWebPlugin.cpp
21

-> KReportDesignerItemWeb

src/plugins/web/KReportWebPlugin.h
25

-> KReportWebPlugin

src/renderer/KReportAsyncItemManager_p.h
32–33

move to KReportASyncItemManager_p.cpp

33

-> namespace KReportPrivate class AsyncItemManager

src/renderer/KReportHTMLCSSRenderer_p.h
25–27

-> namespace KReportPrivate class HTMLCSSRenderer

src/renderer/KReportHTMLTableRenderer_p.h
25–27

-> namespace KReportPrivate class HTMLTableRenderer

src/renderer/scripting/KReportScriptLine.h
36

For now that's correct change for all the scripting classes, just note the comment I added about scripting in T709.

src/wrtembed/KReportDesigner.cpp
67

Perhaps no need to have it in a separate class? Move contents to KReportDesigner::Private?

src/wrtembed/KReportDesignerScene.h
38

-> KReportDesignerScene

src/wrtembed/KReportDesignerSection.cpp
348

-> KReportDesignerSectionTitle

src/wrtembed/KReportDesignerSectionDetail.h
36

-> KReportDesignerSectionDetail

src/wrtembed/KReportDesignerSectionDetailGroup.cpp
150

BTW: yes -> visible

src/wrtembed/KReportDesignerSectionDetailGroup.h
36

-> KReportDesignerSectionDetailGroup

src/wrtembed/KReportDesignerView.h
26

-> KReportDesignerScene

This revision now requires changes to proceed.Oct 11 2015, 8:35 PM
piggz marked 9 inline comments as done.Oct 19 2015, 8:36 PM
piggz added inline comments.
src/common/KReportItemLine.h
57–58

why? weight should always be >= 0 ?

staniek added inline comments.Oct 19 2015, 9:41 PM
src/common/KReportItemLine.h
57–58

Yes but following the Qt API design, if we use int everywhere code is simpler. The unsigned would be casted to int in real apps, e.g. when comparing with indices. We had many unsigned in KDb for example and now without it I see things are easier to use.

piggz marked 7 inline comments as done.Oct 20 2015, 9:19 PM
piggz added inline comments.
src/common/KReportItemBase.cpp
46

Removed this class and used new KReportLineStyle that you created using sdc

piggz marked 4 inline comments as done.Oct 21 2015, 8:50 PM
piggz added inline comments.
src/renderer/KReportPage.h
33

but its not an item in the sense of a report 'item' (object)

piggz marked 36 inline comments as done.Oct 22 2015, 3:08 PM
piggz added inline comments.
src/common/KReportPageOptions.h
27

i will do this after the rename, no no point making const changes

src/renderer/KReportODTRenderer.h
10

Do you also want this in KReportPrivate:: ?

src/wrtembed/KReportDesigner.cpp
67

later change?

piggz updated this revision to Diff 1038.Oct 22 2015, 3:09 PM
piggz edited edge metadata.
piggz marked an inline comment as done.
  • Address most of the comments from staniek
  • Merge branch 'master' of git://anongit.kde.org/kreport
staniek requested changes to this revision.Oct 23 2015, 11:13 PM
staniek edited edge metadata.

Much improved, thanks!

src/common/KReportAsyncItemBase.h
20–21

Why KO and Ko ?

src/common/KReportDocument.h
19–20

why reverted?

src/common/KReportItemBase.cpp
46

Very good.

src/common/KReportPageOptions.h
27

ok

src/renderer/KReportHTMLCSSRenderer_p.cpp
19–21

why reverted?

src/renderer/KReportHTMLTableRenderer_p.cpp
19–20

why reverted?

src/renderer/KReportHTMLTableRenderer_p.h
18–19

why reverted?

src/renderer/KReportODTRenderer.h
10

OK

src/renderer/KReportPrintRenderer_p.cpp
19–23

why reverted?

20

this include shall stay first

src/renderer/KReportPrintRenderer_p.h
17–18

why reverted?

src/renderer/KReportScreenRenderer_p.cpp
19–22

why reverted?

src/renderer/KReportScreenRenderer_p.h
18–20

why reverted?

src/wrtembed/KReportDesigner.cpp
67

ok

src/wrtembed/KReportDesignerScene.cpp
19–25

why reverted?

src/wrtembed/KReportDesignerScene.h
25–26

why reverted?

src/wrtembed/KReportDesignerSectionDetail.h
19–20

KREPORTSECTIONDETAIL_H -> KREPORTDESIGNERSECTIONDETAIL_H

19–20

why reverted?

src/wrtembed/KReportDesignerSectionDetailGroup.h
19–20

KREPORTSECTIONDETAILGROUP_H -> KREPORTDESIGNERSECTIONDETAILGROUP_H

19–20

why reverted?

src/wrtembed/KReportDesignerView.cpp
22–23

why reverted?

src/wrtembed/KReportDesignerView.h
19–20

why reverted?

26

Not done...?

src/wrtembed/KReportSectionEditor.cpp
1

filename?

src/wrtembed/KReportSectionEditor.h
1

filename?

This revision now requires changes to proceed.Oct 23 2015, 11:13 PM
piggz added inline comments.Oct 25 2015, 3:00 PM
src/wrtembed/KReportDesignerSectionDetailGroup.h
19–21

i dont understand, what is reverted?

src/wrtembed/KReportDesignerView.cpp
22–24

what is reverted?

src/wrtembed/KReportDesignerView.h
26

to be KReportDesignerView? not SceneView?

src/wrtembed/KReportSectionEditor.h
1

i dont understand

piggz added a comment.Oct 25 2015, 3:00 PM

jstaniek, i dont understand the comments about things being reverted, could you clarify, ta

staniek added inline comments.Oct 25 2015, 7:17 PM
src/wrtembed/KReportSectionEditor.h
1

I just clicked a diff between Diff 1 and Diff 2 and this is example result:

staniek added inline comments.Oct 25 2015, 7:36 PM
src/wrtembed/KReportDesignerView.h
26

Yes, KReportDesignerScene would be good

piggz marked 16 inline comments as done.Oct 25 2015, 9:51 PM
piggz added inline comments.
src/wrtembed/KReportDesignerView.h
26

We already have KReportDesignerScene .... this is the View :)

This revision was automatically updated to reflect the committed changes.
staniek reopened this revision.Oct 26 2015, 2:04 AM

Please look at the D383-big-rename branch. I've renamed the remaining Ko* symbols for you and the KReportDesignerView. Except in ods/ and odtframe/.

If OK we could commit it on Monday.

src/wrtembed/KReportDesignerView.h
26

I am sorry. I mean KReportDesignerView would be best IMHO.
KReportSceneView is a mix of separate terms: scene and view.

Also this is a Designer's class.

This revision now requires changes to proceed.Oct 26 2015, 2:04 AM
staniek accepted this revision.Dec 9 2015, 4:44 PM
staniek edited edge metadata.

Let's close

This revision is now accepted and ready to land.Dec 9 2015, 4:44 PM
piggz closed this revision.Jan 13 2016, 8:36 PM
piggz marked 19 inline comments as done.