[FileIndexerConfig] Replace config QString,bool pair with dedicated class
ClosedPublic

Authored by bruns on Sun, Mar 22, 1:42 PM.

Details

Summary

entry.path/entry.isIncluded is more readable than entry.first/enty.second.

Also replace the homegrown insertSort with std::lower_bound + insert.

Test Plan

ctest -R fileindexerconfigtest

Diff Detail

Repository
R293 Baloo
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
bruns created this revision.Sun, Mar 22, 1:42 PM
Restricted Application added projects: Frameworks, Baloo. · View Herald TranscriptSun, Mar 22, 1:42 PM
Restricted Application added a subscriber: kde-frameworks-devel. · View Herald Transcript
bruns requested review of this revision.Sun, Mar 22, 1:42 PM
ngraham accepted this revision.Wed, Mar 25, 4:26 PM
This revision is now accepted and ready to land.Wed, Mar 25, 4:26 PM
This revision was automatically updated to reflect the committed changes.