make the libssh finder ensure the new ssh target is set
ClosedPublic

Authored by sitter on Wed, Nov 6, 12:59 PM.

Details

Summary

starting with 0.9.2 the libssh cmake config defines a new ssh imported
target, use this as the new gold standard and ensure older versions
are compatible

broken ubuntu: no cmake config -> manual finder -> target injected
0.9.0 and earlier: cmake config -> target injected
0.9.2: cmake config -> target already defined; noop

(0.9.1 is broken as it neither matches the old nor the new expectation)

Test Plan

no cmake config -> target injected
older cmake config -> target injected
newer cmake config (with merge request) -> noop

Diff Detail

Repository
R320 KIO Extras
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
sitter created this revision.Wed, Nov 6, 12:59 PM
Restricted Application added projects: Dolphin, Frameworks. · View Herald TranscriptWed, Nov 6, 12:59 PM
Restricted Application added subscribers: kfm-devel, kde-frameworks-devel. · View Herald Transcript
sitter requested review of this revision.Wed, Nov 6, 12:59 PM
asn added a subscriber: asn.Thu, Nov 7, 3:41 PM

Thanks Harald, this is an awesome idea!

https://www.libssh.org/2019/11/07/libssh-0-9-2/

This revision was not accepted when it landed; it landed in state Needs Review.Thu, Nov 14, 11:51 AM
This revision was automatically updated to reflect the committed changes.