Builds
Details
Details
Diff Detail
Diff Detail
- Repository
- R127 KWayland
- Branch
- master
- Lint
Lint OK - Unit
No Unit Test Coverage - Build Status
Buildable 16675 Build 16693: arc lint + arc unit
autotests/client/test_wayland_surface.cpp | ||
---|---|---|
395–396 | I know it's unrelated, but erasing smart pointer types perhaps is not the greatest idea. Could you please use concrete type instead of auto while you're on this? | |
src/client/region.cpp | ||
62 | Heh, you could make it a bit simpler: for (const QRect &rect : region) { ... } | |
src/server/surface_interface_p.h | ||
27–28 | Keep includes sorted please. |
autotests/client/test_wayland_surface.cpp | ||
---|---|---|
395–396 | Putting auto everywhere is a terrible thing! Surely it makes refactoring a bit easier, however you kill readability by erasing types. Qt has a really good auto keyword usage guideline. https://wiki.qt.io/Coding_Conventions#auto_Keyword |