I screwed up the names - plurals vs singulars here as Agent can contain several agents - having Agent::current looked better than Agents::current.
We'll need to do something about this for Qt6/KF6.
Now, I can not guarantee this, but I think we will have a smaller API change if these were all named in plural. In that case, with the implicit conversion from QStringList to Agent and others, only one set function should be needed for each of these.
void setTypes(const Terms::Type &types);
void setTypes(const QStringList &types); void setType(const Terms::Type &types);
What do you think?