One proposal i have is actually saying we don't support poppler 0.50
poppler-0.50.0 was released on Dec 15, 2016, we require Qt 5.8.0 released on January 26, 2017 and KF5 5.44.0 released on March 10, 2018
Any reason you want to support such an old poppler?
My OS (AstraLinux) is based on Debian stretch and has poppler 0.48, Qt 5.11, KF5 5.46.
And probably it will be a headache to update poppler on it, cause it's rather low-level library (cups-filters depends on it).
Now if somebody spends time testing this and makes sure it doesn't regress for the rest of us using reasonable pakcages i'm not against this landing.
Kind of surprised you're removing a class though. I mean i would like to think i added it for a reason