Fix build with poppler < 0.51
AbandonedPublic

Authored by volkov on May 23 2019, 10:28 AM.

Details

Reviewers
sander
Group Reviewers
Okular

Diff Detail

Repository
R223 Okular
Branch
Applications/19.04
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 12094
Build 12112: arc lint + arc unit
volkov created this revision.May 23 2019, 10:28 AM
Restricted Application added a project: Okular. · View Herald TranscriptMay 23 2019, 10:28 AM
Restricted Application added a subscriber: okular-devel. · View Herald Transcript
volkov requested review of this revision.May 23 2019, 10:28 AM
aacid added a subscriber: aacid.May 24 2019, 8:26 PM

One proposal i have is actually saying we don't support poppler 0.50

poppler-0.50.0 was released on Dec 15, 2016, we require Qt 5.8.0 released on January 26, 2017 and KF5 5.44.0 released on March 10, 2018

Any reason you want to support such an old poppler?

My OS (AstraLinux) is based on Debian stretch and has poppler 0.48, Qt 5.11, KF5 5.46.
And probably it will be a headache to update poppler on it, cause it's rather low-level library (cups-filters depends on it).

You're hurting yourself for no reason. You either stay in old versions or use new versions. Mix and match is a good recipe for pain like you're experiencing here.

Now if somebody spends time testing this and makes sure it doesn't regress for the rest of us using reasonable pakcages i'm not against this landing.

Kind of surprised you're removing a class though. I mean i would like to think i added it for a reason

My OS (AstraLinux) is based on Debian stretch and has poppler 0.48, Qt 5.11, KF5 5.46.
And probably it will be a headache to update poppler on it, cause it's rather low-level library (cups-filters depends on it).

Is there a astralinux docker image i could use?

My OS (AstraLinux) is based on Debian stretch and has poppler 0.48, Qt 5.11, KF5 5.46.
And probably it will be a headache to update poppler on it, cause it's rather low-level library (cups-filters depends on it).

Is there a astralinux docker image i could use?

It is a rebranded version of Debian stable (9.9, Stretch) for Russian military and government purposes. So Debian images (poppler 0.48 included) should be fine:

https://hub.docker.com/_/debian/

aacid added a comment.Jun 22 2019, 1:06 PM

My OS (AstraLinux) is based on Debian stretch and has poppler 0.48, Qt 5.11, KF5 5.46.
And probably it will be a headache to update poppler on it, cause it's rather low-level library (cups-filters depends on it).

Is there a astralinux docker image i could use?

It is a rebranded version of Debian stable (9.9, Stretch) for Russian military and government purposes. So Debian images (poppler 0.48 included) should be fine:

https://hub.docker.com/_/debian/

But they may have some other stuff on top? i tried with Debian Stable and it doesn't have an ECM new enough to build okular.

volkov abandoned this revision.Mon, Jun 24, 10:21 AM

It's specific only for AstraLinux.