This matters for user code doing some more advanced layouting or size
computations, especially once we remove the hardcoded minimum sizes
in here for proper high dpi support.
Details
Details
Diff Detail
Diff Detail
- Repository
- R280 Prison
- Branch
- arcpatch-D27730
- Lint
No Linters Available - Unit
No Unit Test Coverage - Build Status
Buildable 23690 Build 23708: arc lint + arc unit
Comment Actions
I'm not sure I like the implementation. The current AbstractBarcode can also be implemented, at least theoretically, by software providing other barcodes that forever reason isn't available here. I have at least done that for some PoC ports of other things.
I suggest instead having a
enum class BarcodeDimensions { 1d, 2d, 3d, 4d } ;
perhaps with better names, and then just a barcodeDimensions() method on AbstractBarcode that can be switched over.