Fix comic applet appearance
AbandonedPublic

Authored by gladhorn on Aug 26 2016, 7:25 PM.

Details

Reviewers
None
Summary

Move all the code that was supposed to be the applet into
Plasmoid.fullReprensentation. Otherwise only the compact representation
is shown which is just the icon.

BUG: 361928

Diff Detail

Repository
R114 Plasma Addons
Lint
No Linters Available
Unit
No Unit Test Coverage
gladhorn updated this revision to Diff 6307.Aug 26 2016, 7:25 PM
gladhorn retitled this revision from to Fix comic applet appearance.
gladhorn updated this object.
gladhorn edited the test plan for this revision. (Show Details)
Restricted Application added a project: Plasma. · View Herald TranscriptAug 26 2016, 7:25 PM
Restricted Application added a subscriber: plasma-devel. · View Herald Transcript
gladhorn updated this revision to Diff 6308.Aug 26 2016, 7:27 PM

Testing arc diff update... Just a small improvement to the indentation look.

Thanks, but this is isn't the right fix

comic applet hasn't changed which means it's a change in plasma-framework (probably) fixing it here will still leave potentially 3rd party applets broken, and if it is plasma-framework will still leave it broken for users of Plasma 5.6 or older.

In theory what should happen is the root item will be used as the full representation if no fullRepresentation exists.

Once fixed, we can merge this patch anyway, as I hate that undocumented magic above, and this is a lot more readable.

Edit:

I was wrong about this being a regression. It seems this has always been here.

the switch between showing compact and full is:
Math.max(minimumWidth, Math.min(centerLayout.comicData.image.nativeWidth * 0.6, implicitWidth)); or implicitWidth

both minimumWidth and implicitWidth are fricking enormous.

Which means by default we'll show the compact on startup, and until the plasmoid is made even bigger than the already huge default size.
(and in fact dragging it larger in both directions does reveal the components correctly)

Your patch works by breaking the binding on minimumWidth used in the switchWidth, so that it now always shows the full version.
Which is replacing it by a different bug.

applets/comic/package/contents/ui/main.qml
33

you've broken this binding. minimumWidth is no longer declared within this scope.

though this whole line makes little sense anwyay - see comment below.

mart added a subscriber: mart.Aug 29 2016, 9:58 AM

yes, it should just get given sane minumuwidth/switchwidth instead

gladhorn updated this revision to Diff 6448.Sep 5 2016, 2:48 PM

Change patch to just set sane switchWidth and Height

gladhorn abandoned this revision.Sep 5 2016, 2:53 PM

Superseeded by D2664