- Reduce redundant text
- Change some argument names in the hope it's an improvement
- Update a code example to fit new style
- Try to improve some wording
- Add some @see, @p and such, but probably not all will be needed due to "auto reference"
- Fix some outdated info
- Group Reviewers
- R39:efa926274947: KTextEditor::Message: Review documentation
Unit Tests Skipped
Now you are mixing documentation changes with code changes. I would have preferred to have different review requests, especially since the documentation part was already reviewed. Further, I would prefer autoHideDelay instead of just delay. If we use "delay" only, then the question immediately arises "the delay of what"? With this in mind, the naming of "autoHide" as better, since at least the context was clear. I will take care of the documentation now, but will not take care of the renaming for the reason given.
Sorry for the hassle, will revert the update
Further, I would prefer autoHideDelay instead of just delay.
Are you refering here to the header or the code part?
The old name in the header was "autoHideTimeR" which is pretty wrong. So have I to change this in the header/docu to "autoHideDelay"? Or perhaps "autoHideTime"? Then is the change minimal.