Added options to flip the image vertically and horizontally in the right-hand drawer.
Why are you doing that? looks redundant and unnecessary.
This const doesn't add any information, remove.
Needs at least documentation, what's flipVertical(false)? maybe turn the bool into an enum?
Removed const and changed bool to enum for the image flip and remove ambiguous function into a general "flip" function.