Backport fix for 391706 into Frameworks 5.44
Open, Needs TriagePublic

Description

A bug in the Solid framework (https://bugs.kde.org/show_bug.cgi?id=391706 ) broke auto-mounting internal disks (among other things) in Frameworks 5.44 and 5.45. The bug was fixed in 5.46.

However, Kubuntu shipped with 5.44, exposing users to the bug. See for example this bug report from a Kubuntu user that we got yesterday: https://bugs.kde.org/show_bug.cgi?id=397911.

We should consider backporting the fix (https://cgit.kde.org/solid.git/commit/?id=122a6cd8989a4bd3096fddea908a1c2b223be62a) to Frameworks 5.44.

ngraham created this task.Aug 27 2018, 7:36 PM

Please file a bug report in Launchpad and fill out the SRU bug template, and I'll be happy to hustle this through.

Ah OK, is that the correct procedure for this?

Yup. I don't mind taking things from Phab tasks, but the SRU team needs a bug report. ๐Ÿ˜‰

Gotcha, thanks. One reason why I prefer Phab is that I can never find the right component on Launchpad. I am not able to find the Launchpad page corresponding to the KDE Solid Framework package. Where should I file it?

Gotcha, thanks. One reason why I prefer Phab is that I can never find the right component on Launchpad. I am not able to find the Launchpad page corresponding to the KDE Solid Framework package. Where should I file it?

https://launchpad.net/ubuntu/+source/solid

Report bug link top right (ish)

@ngraham So this is not the same as?

Ok. Partially it is. Same solid commit

It's a little different. There were two attempts to fix the issue. T8471 requested that the first one (which didn't work) be backported. Since it didn't work, I closed the task. Later an actual fix for the issue was made, that we have all verified actually works. :) This is https://cgit.kde.org/solid.git/commit/?id=122a6cd8989a4bd3096fddea908a1c2b223be62a

The new Launchpad bug tracking the actual fix is https://bugs.launchpad.net/ubuntu/+source/solid/+bug/1789292.

It's a little different.

Doesn't look it. The solid commit you link to in both is precisely the same commit.

rikmills added a comment.EditedAug 27 2018, 8:11 PM

I will mark the original bug as invalid anyway.

No point confusing it with 2 open. :)

EDIT Too slow. LOL

Ah, the history is coming back to me now. :)

It appears that https://cgit.kde.org/solid.git/commit/?id=122a6cd8989a4bd3096fddea908a1c2b223be62a did in fact fix the automount bug, and the people who were still having problems were suffering from unrelated issues, though I didn't know this at the time when I closed T8471.

Either way, the point is, the automount woes appear to be fixed now and we're not getting bug reports anymore.

Sometimes I wish KDE Frameworks had a slower release cycle so we didn't have to release so many regressions that get fixed 1-2 months later. :( Makes life hard for stable release distros like Kubuntu.

Ok. In that case the new bug with the single commit fix for solid can stand as the new tracker for this. :)

rikmills moved this task from Inbox to Packaging / Devel on the Kubuntu board.Aug 28 2018, 8:40 PM

I guess @tsimonq2 is not doing this.