Double trash on desktop - 18.04 release
Closed, InvalidPublic

Description

Don't send me to ...

If you create a text file on the desktop and then you send it to trash, this unexpected behavior will occur.

I thought this had been fixed. It's nothing critical but you know ... I can't take it to businesses and tell them to donate to the project.

@rikmills Can you replicate this? It only occurs after fresh install, then it goes away. Very annoying nonetheless. I can upload a video capturing it, if necessary. Please tell me how can I help on this one.

Can confirm. :(

If I kill and restart plasmashell the behavior stops happening.

Can you please file an upstream bug report and attach a screen recording? Thanks!

Actually, cannot reproduce in Neon.

I recall some changes in Plasma 5.13 to improve the Trash-on-Desktop situation, so it may have already been fixed upstream. Let me dig...

ngraham moved this task from Inbox to Packaging / Devel on the Kubuntu board.Thu, Jul 5, 12:42 PM
ngraham triaged this task as High priority.

This was fixed upstream with https://cgit.kde.org/plasma-workspace.git/commit/?id=ee48796ec5561f540ed8b328a302e44b4364a234

That change went into 5.13, so we will need to either wait for Plasma 5.13 or backport the fix to 5.12.

It does seem like a somewhat important bug to fix given that we ship with a Trash on the desktop by default. Recommend backporting the fix, @rikmills. The diff is pretty small and comprehensible.

ngraham lowered the priority of this task from High to Normal.Thu, Jul 5, 12:43 PM

FWIW I *can* reproduce this on Neon with Plasma 5.13.2, which should already have the fix you linked to. But I had to create a *new* Activity to trigger the bug (was not triggered in existing Activities).

FWIW I *can* reproduce this on Neon with Plasma 5.13.2, which should already have the fix you linked to. But I had to create a *new* Activity to trigger the bug (was not triggered in existing Activities).

So *can* I. It wasn't there in Neon User Edition with Plasma 5.12 but now it is.

If I kill and restart plasmashell the behavior stops happening.

It only happens once. After fresh install. After reboot it never shows again. Which is consistent with what you're saying.

ngraham closed this task as Invalid.Fri, Jul 6, 12:56 PM

Yeah, I had to create a new account to get it to happen. If this happens in Neon too, it's not Kubuntu-specific, so let's track the upstream bug report instead. Thanks everyone!

Side note: I really wish Phabricator had more resolution statuses. "Invalid" isn't, well, valid, but there's nothing more appropriate...