Test Qt 5.9
Closed, ResolvedPublic

mparillo created this task.Jul 18 2017, 8:49 PM

Dmitry Shachnev <mitya57@ubuntu.com>
Attachments4:33 PM (15 minutes ago)

to kubuntu-devel
Dear Kubuntuers,

As you may already know, I am preparing the Qt 5.9 transition in a PPA [1].

Now it got to the point when we are mostly ready for publishing it into
the main Ubuntu archive, but I would like to gather some feedback first
and make sure everything works fine with that version.

If you are running Artful and have some time for testing it, please add the
PPA, test the desktop and your favourite Qt/KDE applications, and report
any regressions to me.

$ sudo add-apt-repository ppa:ci-train-ppa-service/2819
$ sudo apt update
$ sudo apt full-upgrade

I would like to land it to archive this week, but it is currently blocked
by Ubuntu Touch packages removal, so I am not yet sure about the exact dates.

[1]: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/2819/+packages

Dmitry Shachnev

mparillo added a comment.EditedJul 18 2017, 9:01 PM

I added the PPA to my AA VM, but Discover must have been holding a lock, so I could not upgrade using the konsole.
Instead, I used Discover, which reported 100 updates and it warned me:
The following packages will be removed by the update: qtvirtualkeyboard-plugin (5.7.1+dfsg-1).
After a re-boot, I sign in through SDDM, and I get a black screen with a box:
KWin is unstable. It seems to have crashed several times in a row.
You can select another window manager to run:
kwin_x11
I click OK, but I get a black screen with an oxygen cursor.

Hi @mparillo!

The following packages will be removed by the update: qtvirtualkeyboard-plugin (5.7.1+dfsg-1).

This package is perfectly installable for me. What happens if you try to run apt install qtvirtualkeyboard-plugin?

KWin is unstable. It seems to have crashed several times in a row.
You can select another window manager to run:
kwin_x11

There were some known problems with KWin/Wayland and Qt 5.9, however according to @graesslin’s blog post most of them should be all fixed in Qt 5.9.1, at least it should not crash on start. It would be nice if you could obtain a stack trace of the crash.

I will try to do some testing/debugging myself, but I am not yet sure when I will have time for that.

mparillo renamed this task from Test Qt5.9 to Test Qt 5.9.Jul 18 2017, 10:15 PM

Hi @mparillo!

The following packages will be removed by the update: qtvirtualkeyboard-plugin (5.7.1+dfsg-1).

This package is perfectly installable for me. What happens if you try to run apt install qtvirtualkeyboard-plugin?

Unfortunately, my host is capturing the control alt f3 I generally use to get to a tty, so I cannot try this.

KWin is unstable. It seems to have crashed several times in a row.
You can select another window manager to run:
kwin_x11

There were some known problems with KWin/Wayland and Qt 5.9, however according to @graesslin’s blog post most of them should be all fixed in Qt 5.9.1, at least it should not crash on start. It would be nice if you could obtain a stack trace of the crash.

I will try to do some testing/debugging myself, but I am not yet sure when I will have time for that.

Same thing (not that I ever was good at running the debugging stuff), but since my host is capturing the control alt f3 I generally use to get to a tty, so I cannot try even try (though I think kubuntu used to have a GUI program to create launchpad bugs automagically, but obviously that does not help either.

You did not say what is your VM, but in case it’s Virtualbox, you can try using Host key + F3 to switch to a TTY.

You did not say what is your VM, but in case it’s Virtualbox, you can try using Host key + F3 to switch to a TTY.

Thank you. It worked. I cannot install qtvirtualkeyboard-plugin because it has unmet dependencies:

Depends: libhunspell-1.6-0 but it is not installable. 
E: Unable to correct problems, you have held broken packages.
rikmills added a subscriber: rikmills.EditedJul 19 2017, 6:00 AM

Thank you. It worked. I cannot install qtvirtualkeyboard-plugin because it has unmet dependencies:

Depends: libhunspell-1.6-0 but it is not installable. 
E: Unable to correct problems, you have held broken packages.

hunspell transition to v1.6 is currently stuck in -proposed for artful

dmitryshachnev added a comment.EditedJul 19 2017, 7:47 AM

hunspell transition to v1.6 is currently stuck in -proposed for artful

I looked at it. Looks like it is stuck because Libreoffice failed to build on i386, and a kernel update is needed to fix that.

From IRC:

<seb128> oSoMon handed me a libreoffice update that disable tests as a workaround before going on holidays but I would prefer the kernel to be fixed because if we ignore the issue at build we are still going to get a libreoffice that segfaults at runtime

dmitryshachnev added a comment.EditedJul 19 2017, 10:52 AM

FWIW kwin_x11 does not crash for me in a daily Kubuntu Artful image with my PPA added, however I get lots of these warnings printed on startup:

QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setWindow: Painter not active
...

and then warnings of these two kinds:

QXcbConnection: XCB error: 9 (BadDrawable), sequence: 1225, resource id: 0, major code: 14 (GetGeometry), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 4291, resource id: 58720408, major code: 20 (GetProperty), minor code: 0

Upd: the Wayland session works fine too, after I rebuilt KWin in the PPA.

‎[07:12] ‎<‎BluesKaj‎>‎ mparillo, so far so good with the "Qt 5.9 transition in a PPA" no crashes or glitches with dolphin,system settings, chrome. muon, konversation, vlc, mpv or nvidia graphics and intel audio

So, today, BluesKaj was successful, as was I. From the resolved bug report: https://bugs.kde.org/show_bug.cgi?id=382483

Strange, but yesterday, before I tried to add the other packages, I routinely sudo apt update && sudo apt full-upgrade -y.

As usual, I got a few new packages yesterday, and today, today when I intended to add the debugging symbols via the tty, instead plasma started normally, but I do not know what might have caused the success today. Anyway, today, I could launch krunner to invoke kinfocenter (which reports Plasma 5.10.3, FW 5.36, and Qt 5.9.1). The kicker application launcher works, and I could launch discover, kate, system settings, konsole, konversation, and ksysguard.

Since I have rebooted my VM three times, all successfully, I will try to close this bug with resolved, fixed.

Once there are the plasma 5.10.4 rebuilds in the ppa, I might be brave enough to test!

‎[09:36] ‎<‎mamarley‎>‎ Are we talking about the Qt5.9 PPA? I've been running that for a few days now (along with the various staging- PPAs and some packages from those that I rebuilt myself) and I haven't had any issues. :)

clivej moved this task from Inbox to Packaging / Devel on the Kubuntu board.Aug 19 2017, 12:44 PM
clivej triaged this task as Normal priority.
clivej added a subscriber: clivej.

We added the Qt5.9 PPA to unstable PPA and artful is now building using it. I have been using the packages from unstable and everything seems to be working correctly.

QT 5.9.1 is stable on 2 boxes (real HW) here.

clivej closed this task as Resolved.Sep 14 2017, 11:54 AM
clivej claimed this task.