CMake 3.1 is the actually required version

Authored by heikobecker on Sep 12 2017, 4:55 PM.



CXX_STANDARD is only available since 3.1.
$ git show 913394af2: cmTarget: Add CXX_STANDARD and CXX_EXTENSION...
$ git tag --contains 913394af2 | head -n: v3.1.0

3.1 also has CMakePackageConfigHelpers (available since 3.0),
allowing to drop ECMPackageConfigHelpers (it actually fixes a CMake
warning when requiring >=3.0).

Furthermore move cmake_minimum_required(VERSION 3.1 FATAL_ERROR) to
the top of CMakeLists.txt like suggested by CMake's documentation.

Test Plan

cmake .. & ninja

Diff Detail

R108 KWin
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.
heikobecker created this revision.Sep 12 2017, 4:55 PM
Restricted Application added a project: KWin. · View Herald TranscriptSep 12 2017, 4:55 PM
Restricted Application added subscribers: kwin, plasma-devel. · View Herald Transcript
heikobecker edited the summary of this revision. (Show Details)Sep 12 2017, 4:56 PM
graesslin accepted this revision.Sep 12 2017, 5:00 PM
graesslin added a subscriber: graesslin.

I had no idea that this requires a newer CMake. Thanks for fixing!

This revision is now accepted and ready to land.Sep 12 2017, 5:00 PM
This revision was automatically updated to reflect the committed changes.