Remove the support for python 2
ClosedPublic

Authored by asemke on Tue, Feb 11, 8:10 PM.

Details

Summary

The python community is sunsetting the support of python2 (https://python3statement.org/) and we should follow these activities to drop python2 in 2020. This patch removes python2 from Cantor. Old worksheets created with python2 will be moved to using python3 on load - there is a info message box to the user to notify him/her about this.

Diff Detail

Lint
Lint Skipped
Unit
Unit Tests Skipped
asemke created this revision.Tue, Feb 11, 8:10 PM
Restricted Application added a project: KDE Edu. · View Herald TranscriptTue, Feb 11, 8:10 PM
Restricted Application added a subscriber: kde-edu. · View Herald Transcript
asemke requested review of this revision.Tue, Feb 11, 8:10 PM
aacid accepted this revision.Tue, Feb 11, 9:15 PM
aacid added a subscriber: aacid.

seems reasonable

This revision is now accepted and ready to land.Tue, Feb 11, 9:15 PM
sirgienko requested changes to this revision.Wed, Feb 12, 8:27 AM

Need support for Jupyter notebooks, based on python2.

This revision now requires changes to proceed.Wed, Feb 12, 8:27 AM
asemke updated this revision to Diff 75573.Wed, Feb 12, 7:25 PM

Added similar logic for Jupyter notebooks.

sirgienko accepted this revision.Wed, Feb 12, 7:30 PM
This revision is now accepted and ready to land.Wed, Feb 12, 7:30 PM
asemke closed this revision.Wed, Feb 12, 7:35 PM