[windowsystem] Fix compilation with no-deprecated build of KWindowSystem
ClosedPublic

Authored by zzag on Mon, Jan 13, 10:55 PM.

Details

Summary

This change ensures that kwayland-integration can be built with a
version of KWS that doesn't have any deprecated stuff. I assume that no
distro ships such builds of KWS and it's only a developer thing.

I didn't backport KWINDOWSYSTEM_BUILD_DEPRECATED_SINCE macro because
the next release of Plasma (5.18) depends on KF 5.66.

Diff Detail

Repository
R130 Frameworks integration plugin using KWayland
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
zzag created this revision.Mon, Jan 13, 10:55 PM
Restricted Application added a project: Plasma. · View Herald TranscriptMon, Jan 13, 10:55 PM
Restricted Application added a subscriber: plasma-devel. · View Herald Transcript
zzag requested review of this revision.Mon, Jan 13, 10:55 PM
davidedmundson accepted this revision.Wed, Jan 15, 4:34 PM
This revision is now accepted and ready to land.Wed, Jan 15, 4:34 PM
This revision was automatically updated to reflect the committed changes.