Downgrade required ECM version to 5.26.0
AbandonedPublic

Authored by antlarr on Dec 13 2016, 9:18 AM.

Details

Reviewers
mlaurent
Group Reviewers
KDE PIM
Summary

kholidays doesn't really need ECM 5.28.0, so this commit
modifies that to only require ECM 5.26.0 so it builds
with a LTS KF5 release.

Test Plan

Diff Detail

Repository
R175 PIM: KHolidays
Branch
master
Lint
No Linters Available
Unit
No Unit Test Coverage
antlarr updated this revision to Diff 8964.Dec 13 2016, 9:18 AM
antlarr retitled this revision from to Downgrade required ECM version to 5.26.0.
antlarr updated this object.
antlarr edited the test plan for this revision. (Show Details)
Restricted Application added a project: KDE PIM. · View Herald TranscriptDec 13 2016, 9:18 AM
Restricted Application added a subscriber: kde-pim. · View Herald Transcript
antlarr edited the test plan for this revision. (Show Details)Dec 13 2016, 9:22 AM
antlarr updated this revision to Diff 8966.Dec 13 2016, 10:07 AM
  • Set the required KF5 version (5.26.0) with a variable

Hi,.
Don't change KF5_VERSION to REQUIRED_KF5_VERSION I use KF5_VERSION to upgrade all packages.

And not necessary to downgrade version here as by default I use last kf5 version for kdepim. So it will not useful to downgrade here.
So you can create patchs for your packages but for sure not in official release.

Regards.

mlaurent requested changes to this revision.Dec 13 2016, 2:18 PM
mlaurent added a reviewer: mlaurent.
This revision now requires changes to proceed.Dec 13 2016, 2:18 PM
antlarr updated this revision to Diff 8971.Dec 13 2016, 2:28 PM
antlarr edited edge metadata.
  • Change back REQUIRED_KF5_VERSION to KF5_VERSION
antlarr abandoned this revision.Dec 13 2016, 2:45 PM

It seems other parts of kdepim already really require KF5 5.28, so there's no point in requiring less here