Update diff for revision: https://phabricator.kde.org/D21684
Diff Detail
Diff Detail
- Repository
- R262 LabPlot
- Lint
Lint Skipped - Unit
Unit Tests Skipped
src/backend/hypothesis_test/HypothesisTest.cpp | ||
---|---|---|
186 | QString::isEmpty() | |
221 | "At least" | |
229 | readable error codes would be more convenient. | |
244 | please indent to make it easier to read. | |
250 | "t_value" would be clearer | |
255 | why 9? please comment. | |
280 | UTF8_QSTRING()? | |
326 | why 8? | |
440 | switch (test is an enum) | |
442 | t_value? | |
608 | better use "switch"? | |
618 | double t = ... | |
619 | double df = .. | |
746 | cell1 and cell2 would be more specific. | |
812 | how about returning an error code instead of using n[0] for errors? | |
860 | not "-2"? | |
866 | QString::isEmpty() | |
880 | you can omit braces in one-liners. | |
900 | Maybe better define constant string in the header? | |
src/backend/hypothesis_test/HypothesisTestPrivate.h | ||
81 | order of parameter is different compared to other findStats-functions. | |
src/kdefrontend/dockwidgets/HypothesisTestDock.cpp | ||
87 | still not camelCase :-) | |
517 | translation | |
525 | translation | |
528 | translation | |
src/kdefrontend/dockwidgets/HypothesisTestDock.h | ||
72 | why not use a single variable of type testType? | |
74 | better use an enum for different kinds of test? | |
src/kdefrontend/hypothesis_test/HypothesisTestView.cpp | ||
68 | please define extra variable for font size |
Comment Actions
- changed Summary Result TreeView/model to list of QLabels.
- Added more helper functions
- Used Error Codes
- Used Switch for enums
- And tried to do some more changes according to previous comments.