Simple but maybe useful changes.
[x] KReportPreRenderer::reportData() can be confused with KReportDesigner::reportData(); rename to KReportPreRenderer::document()
[ ] KReportData -> KReportDataSource (reason: it does not actually contain data but offers means to retrieve data, a source)
[ ] value(unsigned int) -> value(int) (as in KDb, Qt...)
[ ] addExpression() would be better addCondition()?