Doesn't seem relevant anymore
Alternative approach without Q_NAMESPACE_EXPORT, which is too new
Haha yes almost exactly like that! Maybe today I'd use a sheet instead of a separate dialog window. But I have great faith that the 2019 David is able to conquer the challenges of 2009. :)
That is excellent!
That is excellent! But in the implementation, mind the "multiple kxmlgui-clients" use case, like konqueror or kdevelop (or kate I guess). It can make things tricky...
(you drop between two clients, how do you know which one should memorize the action into its kxmlgui file?)
Trying to assign anything to Shift+Delete shows the "conflicting shortcuts" error dialog.
is something you can use if you feel bored, i made it mandatory in poppler
Oops, sorry! I added comments to D8773.
Why is this not in the same commit as the related unittest, as is common practice?
The description says this depends on D8773 which isn't approved.
Thanks, now it compiles! I'm not sure it's working perfectly though. I updated D25447 to use this, but it's claiming that my indexer is suspended, while balooctl status disagrees.
please send me a list of urls that don't have https: and I'll add them to the whitelist
Fix "+" in keywords to not act as a word break.
@apol we have a duplicate test in breeze-icons now; is this still relevant?
redo without the export
Can this land?
@bruns, is this good to go now?
Do we dislike iterators now?
We don't, and they still make sense for when you need the key, but range for is just much nier to look at :)
I'm fine with that statement. But are we going to be reviewing changing all the KDE code from iterators to range for? Feels like an overkill to me.
Looks good. But does the highlighting work for RW+CD? I am wondering whether + needs to be added to the weakDeliminator list?
- Corrected URL as review comments
Corrected url to http://www.sphinx-doc.org
The sphinx doc URL is https://www.sphinx-doc.org (it just doesn't work without www)
Unit test added in D25767. AFAICS, both points addressed in this diff are needed to fix the referenced bug.
If we're going to iterate over a whole container, from cbegin() to cend(), and the container isn't going to change in the loop, then IMHO (H for humble :)) range-for would convey the intention better and make the code slightly easier to read/look cleaner.
- Corrections made per review comments.
Reverted some non-working URL's back to http and updated one URL to the correct address
Thanks for the reviews everyone! I'll update the diff and respond to the comments no later than Tuesday
FWIW, this still doesn't work:
- Open a pdf in okular
- Invoke save as, navigate via the keyboard, highlight/select a dir, Enter, the file is saved inside that dir and the dialog closes
Sure, I can land it after saturday.
Though maybe we should wait till after tagging (Saturday) ?
- Add missing layoutChanged/reset signals