Kube: BugsProject
ActivePublic

Recent Activity

Sat, Aug 17

cmollekopf added a comment to T11176: Separate DAV and email servers.

The kube codebase currently indeed makes that assumption and sets the same password on all sink resources of the same account during regular usage.

Sat, Aug 17, 9:58 AM · Kube: Bugs
cmollekopf moved T9296: Certificate Approval Dialog from New to Triaged on the Kube: Bugs board.
Sat, Aug 17, 9:51 AM · Kube: Bugs
cmollekopf moved T10842: Account setup is unnecessarily technical [UX suggestions] from New to Triaged on the Kube: Bugs board.
Sat, Aug 17, 9:51 AM · Kube: Bugs
cmollekopf moved T10326: Somehow make the subject accessible for gpg-encrypted emails from New to Triaged on the Kube: Bugs board.
Sat, Aug 17, 9:51 AM · Kube: Bugs
cmollekopf moved T11106: "An error occured: wrong Passphrase" without a password being requested first from New to Triaged on the Kube: Bugs board.
Sat, Aug 17, 9:51 AM · Kube: Bugs
cmollekopf closed T11397: Certificates broken for kube-project.com as Resolved.

This should be fixed, thanks for the heads up.

Sat, Aug 17, 9:51 AM · Kube: Bugs

Tue, Aug 13

hwilliams added a comment to T11176: Separate DAV and email servers.

Out of interest, would this require the same password to be used for the CardDAV and CalDAV servers as well?

Tue, Aug 13, 3:26 PM · Kube: Bugs
hwilliams created T11397: Certificates broken for kube-project.com.
Tue, Aug 13, 2:50 PM · Kube: Bugs

Wed, Jul 24

cmollekopf added a comment to T11193: New user: after setup, configuration error. Unclear..

It shouldn't. Kube is currently always using PLAIN authentication, but from the capabilities that seems to be correct for zoho (capabilities contains AUTH=PLAIN). You could try to gather another log with the fixed imap server url so we can see what's going on.

Wed, Jul 24, 9:24 AM · Kube: Bugs
brenthuisman added a comment to T11193: New user: after setup, configuration error. Unclear..

IMAP is enabled on my account, I use it with a few clients succesfully, one of which is Kmail. Ofcourse, server and port are only some of the parameters for IMAP (and SMTP) auth, the other I am able to set in Kmail for instance being auth-type (plain, ntlm, cram-md5, and some others). Could it be this?

Wed, Jul 24, 8:42 AM · Kube: Bugs
cmollekopf added a comment to T11193: New user: after setup, configuration error. Unclear..

Unfortunately I cannot help you much more. I've tried signing up for a free testaccount and setting it up as recommended in their documentation https://www.zoho.com/mail/help/imap-access.html, but I always end up with an "Invalid credentials" error (visible only on the console).
You may have to generate an app specific password and you have to enable imap. Anyways, the "Invalid Credentials" error means that kube does successfully connect to the IMAP server, it just can't login with the given credentials. Maybe that was also just because I used a free account, who knows..

Wed, Jul 24, 7:16 AM · Kube: Bugs

Tue, Jul 23

brenthuisman added a comment to T11193: New user: after setup, configuration error. Unclear..

Thanks! For IMAP, I tried 'imap(s)://imappro.zoho.eu:993' but that still gives me the same error. Do you know what I should do to configure IMAP correctly?

Tue, Jul 23, 6:46 PM · Kube: Bugs

Sun, Jul 21

cmollekopf added a comment to T11193: New user: after setup, configuration error. Unclear..

Your server configuration should be something along the lines of: "imaps://imappro.zoho.eu:993" and "smtps://smtp.zoho.eu:465".

Sun, Jul 21, 10:59 AM · Kube: Bugs
cmollekopf closed T11245: Feature Request: Support other Akonadi backends as Wontfix.

Kube and Kontact are entirely separate projects and supporting other akonadi backends means writing a new backend for Sink. I have no plans to work on an EWS backend, so unless somebody steps up that won't be happening anytime soon.
I'll close this request as a wontfix because we won't be doing anything about it at the moment. Of course, if somebody else is willing to do the work then have at it =)

Sun, Jul 21, 10:30 AM · Kube: Bugs

Jul 17 2019

ImNtReal created T11245: Feature Request: Support other Akonadi backends.
Jul 17 2019, 3:19 PM · Kube: Bugs

Jul 15 2019

brenthuisman added a comment to T11193: New user: after setup, configuration error. Unclear..

Here I have the full log obtained after the above steps, running an updated kube (as of 3 minutes ago), and quitting right after. I censored the email adres just in case spammers have found the KDE phabricator instance, but there was no mistake in it ;)

Jul 15 2019, 5:26 PM · Kube: Bugs

Jul 14 2019

cmollekopf added a comment to T11193: New user: after setup, configuration error. Unclear..

I just tried setting up a fresh account without caldav/carddav and it works for me insofar that email starts syncing. There will indeed be configuration errors with an empty url because kube will blindly try to setup caldav/carddav from the urls given.

Jul 14 2019, 8:24 PM · Kube: Bugs
brenthuisman added a comment to T11193: New user: after setup, configuration error. Unclear..

Flatpak, right from the kube website.

Jul 14 2019, 11:21 AM · Kube: Bugs

Jul 13 2019

cmollekopf moved T11176: Separate DAV and email servers from New to Triaged on the Kube: Bugs board.
Jul 13 2019, 11:21 AM · Kube: Bugs
cmollekopf triaged T11176: Separate DAV and email servers as Normal priority.
Jul 13 2019, 11:21 AM · Kube: Bugs
cmollekopf added a comment to T11176: Separate DAV and email servers.

There is no UI for this usecase.

Jul 13 2019, 11:21 AM · Kube: Bugs
cmollekopf triaged T11193: New user: after setup, configuration error. Unclear. as Normal priority.
Jul 13 2019, 11:14 AM · Kube: Bugs
cmollekopf added a comment to T11193: New user: after setup, configuration error. Unclear..

The user visible errors are indeed rather limited/useless. You can get more detailed output by starting kube from the commandline. With flatpak this would be:

Jul 13 2019, 11:14 AM · Kube: Bugs

Jul 9 2019

brenthuisman added a comment to T11193: New user: after setup, configuration error. Unclear..

Could be, but even if I fill out URLs for card/caldav (which indeed would require different credentials from the imap/smtp account) I still get the same error. In both cases: there is nothing wrong with the server URL(s),. Due to the limited error/debug info I can't narrow it down further for a clearer bug report.

Jul 9 2019, 2:50 PM · Kube: Bugs

Jul 8 2019

tristanlins added a comment to T11193: New user: after setup, configuration error. Unclear..

AFAIK the error will occur if you leave CardDAV or CalDAV address blank.
Imo this is related to T11176

Jul 8 2019, 12:58 PM · Kube: Bugs
brenthuisman created T11193: New user: after setup, configuration error. Unclear..
Jul 8 2019, 10:24 AM · Kube: Bugs

Jul 5 2019

hughwilliams created T11176: Separate DAV and email servers.
Jul 5 2019, 11:48 AM · Kube: Bugs

Jun 17 2019

cmollekopf added a comment to T11106: "An error occured: wrong Passphrase" without a password being requested first.

It might be that the issue stems from an invalid mime message that we then map to a passphrase error too liberally in messagepart.cpp EncryptedMessagePart::okDecryptMIME

Jun 17 2019, 11:24 AM · Kube: Bugs
cmollekopf triaged T11106: "An error occured: wrong Passphrase" without a password being requested first as Normal priority.
Jun 17 2019, 11:22 AM · Kube: Bugs

Jun 7 2019

cmollekopf closed T6997: Kube should not download external images by default as Resolved.

We no longer default to HTML mail and therefore don't download external images by default. While there certainly is room for further improvement it's good enough for now IMO

Jun 7 2019, 7:30 PM · Kube (0.8), Kube: Bugs

Apr 25 2019

cmollekopf closed T10843: Kube icon idea as Resolved.
Apr 25 2019, 6:34 AM · Kube: Bugs
bugsbane added a comment to T10843: Kube icon idea.

Ah, no I hadn't seen it. Maybe you could add the current icon to the kube-project.org website and the app. The reason I submitted this proposal was because I didn't see any logo either on the site or in the app, and assumed you didn't have one! o.O

Apr 25 2019, 3:29 AM · Kube: Bugs

Apr 24 2019

cmollekopf added a comment to T10843: Kube icon idea.

Thanks! I don't know if you have seen it or not, but we already have an icon based on very much the same idea =)

Apr 24 2019, 5:33 PM · Kube: Bugs
cmollekopf added a comment to T10842: Account setup is unnecessarily technical [UX suggestions].

Thanks! Constructive criticism is always welcome =)

Apr 24 2019, 5:27 PM · Kube: Bugs
bugsbane created T10843: Kube icon idea.
Apr 24 2019, 5:05 PM · Kube: Bugs
bugsbane triaged T10842: Account setup is unnecessarily technical [UX suggestions] as Wishlist priority.
Apr 24 2019, 3:50 PM · Kube: Bugs

Apr 9 2019

davethompson added a watcher for Kube: Bugs: davethompson.
Apr 9 2019, 12:06 AM

Feb 19 2019

acelankao added a comment to T8722: gmail: work with "app passwords".

I'm wondering if anyone successfully login to gmail account with application password.
I got those errors while login my account.

Feb 19 2019, 1:56 PM · Kube: Bugs

Feb 5 2019

jopetersen added a comment to T8117: Host not found.

Strangely - despite the folders not syncing, sending an email forces the Sent folder to sync with Kube, so you just end up with a Sent folder, and then when you delete you have the Trash folder.

Feb 5 2019, 6:35 PM · Kube: Bugs
jopetersen added a comment to T8117: Host not found.

@cmollekopf what is even more strange is that, with a brand new test Fastmail account it does work.

Feb 5 2019, 11:02 AM · Kube: Bugs

Jan 25 2019

ryanw updated the task description for T10044: Kube doesn't load urls clicked in emails.
Jan 25 2019, 10:43 AM · Kube: Bugs
cmollekopf added a comment to T9823: KIOExec MIME type error.

Please note that the above commit is only in the kube develop (not master) branch and will only be part of the coming 0.8.0 release.

Jan 25 2019, 10:35 AM · Kube: Bugs
cmollekopf closed T10044: Kube doesn't load urls clicked in emails as Resolved.
Jan 25 2019, 10:32 AM · Kube: Bugs
cmollekopf added a comment to T10044: Kube doesn't load urls clicked in emails.

This is fixed in the latest version as of 70fa84e2f23995fa79830c7a9961e101832f8cc6

Jan 25 2019, 10:32 AM · Kube: Bugs

Jan 24 2019

philippka added a comment to T9823: KIOExec MIME type error.

I can confirm the same problem. For testing I have used both the current version from Arch AUR and I have built it from git source today. Both ways show the same error:

Jan 24 2019, 7:06 PM · Kube: Bugs

Jan 14 2019

cmollekopf triaged T10326: Somehow make the subject accessible for gpg-encrypted emails as Normal priority.
Jan 14 2019, 10:49 AM · Kube: Bugs

Jan 7 2019

cmollekopf moved T10288: Entity already in model: $id from New to Confirmed on the Kube: Bugs board.
Jan 7 2019, 9:57 PM · Kube: Bugs, Sink
cmollekopf triaged T10288: Entity already in model: $id as Normal priority.
Jan 7 2019, 9:50 PM · Kube: Bugs, Sink

Dec 25 2018

cmollekopf triaged T10045: Show relative times in message list as Normal priority.
Dec 25 2018, 10:42 AM · Kube: Bugs
cmollekopf merged task T10042: No method to prevent default remote image loading in HTML email into T6997: Kube should not download external images by default.
Dec 25 2018, 10:42 AM · Kube: Bugs