- User Since
- Jul 8 2015, 8:34 AM (242 w, 2 d)
- Lamdafy some data signal handling, for less publics and easier code
- Add a bit of documentation (and remove an unneeded include)
(yeah, this took a bit of work...)
A pre-merging diff, just in case something goes horribly wrong my end
As i was going to do this as part of something else, i obviously think this is a good idea ;) And yes, the thought process behind it was indeed that this is something that'd just make sense in general, not just from QML.
That's a very good idea, yes, go for it! :)
Wed, Feb 26
Tue, Feb 25
Mon, Feb 24
- Switch to using the kaccounts cmake commands
Fri, Feb 21
Thu, Feb 20
Fair bit of work gone on here, but in short, given a patch which handles the
OpenID ID token in the OAuth2 requests in signon-plugin-oauth2, we are now
able to construct a bearer-authenticated request and whatnot. There is more
work to be done, but it seems like things are happening now! Progress.
- Add a text (and thus tooltip) to the account delegate's remove action
Wed, Feb 19
- Add a helpful label when there are no accounts in the list
- Switch to using a Binding
- These are not bookmarks, they're things that should be removed...
Address some of the issues highlighted by @ahiemstra
i think that i'm with @wbauer here - but also Bhushan. This is most definitely a good fallback that i think we'll want in (also, good commenting), but a second patch to pull up more friendly names for accounts where that's possible/make sense/whatnot would also be pretty great. So... accept this one, and suggest further work i think (wow, it's almost like being at uni ;) )
Thanks for the swift decision on that, and i look forward to the visual fix!
Tue, Feb 18
- Remove some test data
Quite right. Looks like some leftovers from before that caching was added, shippit :)
Mon, Feb 17
Fri, Feb 7
Thu, Feb 6
Wed, Feb 5
During some cleanup and addition, i realised it was silly to have
the documentation for knsrc files in the widgets bits, and in two
places. In addition, those places were both at least a bit wrong,
or outdated, and needed fixing anyway, so... consolidate all that
into the README.md file, as it's fairly central anyway. More could
reasonably be done with that section, but this is already better.
Tue, Feb 4
Mon, Feb 3
- Use more modern style for the list initialisation
Address comments by meven and bcooksley
Thu, Jan 30
Thanks to broulik for noticing (or making me notice) this
As suggested by frinring, do not suggest setting a ProvidersUrl unless
it is actually needed.
As D27020, might want to backport this to any branches still being released.
Goodness me, yes please. Land in 5.18 for sure (also perhaps backport to anywhere that's still being released)
Jan 29 2020
Also incidentally, i've just posted D26990 which should hopefully alleviate the issue for people with an up-to-date Frameworks but an out-of-date Artikulate ;)
- Remove some unrelated changes
About half a year ago, yeah - it is a regression, but to ensure people can use it with already-released versions of Frameworks, this'll probably want to go in. Also, since the old code would take either, if people insist on running it against an old version of Frameworks, it should then still work :)
Jan 28 2020
Jan 24 2020
Jan 23 2020
Right, so because it is being brought up by people, i thought i should perhaps just do a touch of an explanation for the thought process that made me arrive at the current design for the NewCommentSheet component and its ability to chose whether or not you are writing a comment or a review. The options that i found can be enumerated as follows:
- A better text for the "be the first" link (i'll try not dither too much)
- Clarify the "be the first" text a touch...
- Don't suggest making reviews if you're writing a reply comment
- Don't pull up a comments model until we actually need it