Use correct object path for PropertiesChanged signal.
This mode can be useful for people concerned about privacy.
backendFramebuffer is a good one.
A client may provide buffers with already rotated contents. Will such clients be a big problem with this patch series?
Hmm, okay, fair enough. Can you rename setKWinFramebuffer to setDefaultFramebufferObject? It's not clear what "kwin framebuffer" is.
If we need to render something into a texture, a GLRenderTarget must be pushed on a stack, e.g.
Tue, Dec 10
Fri, Dec 6
Actually we don't need showStatusOsd() anymore.
Thu, Dec 5
Map only the buffer shape, the decoration rect and the shadow region are in window coordinates
Wed, Dec 4
Heh, it seems you see this revision as one monolithic "remove usages of some deprecated functions and methods" and I see it as "use QWeakPointer::toStrongRef() instead of deprecated QWeakPointer::data(), use qmlRegisterAnonymousType() instead of deprecated qmlRegisterType(), fix initialization of QFlags<T>."
This patch contains a few unrelated changes. Could you please put them in another patches? Also, this patch doesn't remove any methods. ;-)
Tue, Dec 3
IT seems that it was a error during modernize code by using nullptr
Mon, Dec 2
The QSG code looks quite simple, but they go via another QImage buffer.QPainter p(&tmp); p.setCompositionMode(QPainter::CompositionMode_Source); int w = r.width(); //Dave <- image.width+padding*2 int h = r.height(); int iw = image.width(); int ih = image.height(); p.drawImage(1, 1, image); p.drawImage(1, 0, image, 0, 0, iw, 1); p.drawImage(1, h - 1, image, 0, ih - 1, iw, 1); p.drawImage(0, 1, image, 0, 0, 1, ih); p.drawImage(w - 1, 1, image, iw - 1, 0, 1, ih); p.drawImage(0, 0, image, 0, 0, 1, 1); p.drawImage(0, h - 1, image, 0, ih - 1, 1, 1); p.drawImage(w - 1, 0, image, iw - 1, 0, 1, 1); p.drawImage(w - 1, h - 1, image, iw - 1, ih - 1, 1, 1);
Assuming Qt copes with rendering into the image it reads from we could have done the same.
We have the extra complexity of partial updates, but if we have the clipRect set correctly that should just quietly no-op
When was KCModule::markAsChanged introduced?
Sun, Dec 1
Sat, Nov 30
Rename a variable
Add the rotate() function back
Sneaky comment update