Help the KDE PIM team with content for the new Kontact website
Closed, ResolvedPublic

Description

The KDE PIM team has created a new website for Kontact. It can be previewed here:

http://kontact.dvratil.cz/

Let's help them shape the content and make it "punchier", more informative, and in line with our other promo goals.

skadinna created this task.Jul 19 2018, 7:47 PM

First draft looks great! I like how bold the names of the apps appear on the slides. Really jumps out and looks like "confidence".

Friendly suggestions from a former web guy:

  • Some kind of graphic effect around the screenshots. Maybe not the cliche drop-shadow, but something to "pop" them off the background (they're mainly boring plain white screens - they need a little bit of sparkle. Maybe simple including the window decorations would help.)
  • Tighten up the footer and get all that assorted stuff into one slimmer row
  • Under the "Products" dropdown, Kontact is missing an icon
  • See if you can find a way to get the K-Gear logo in there somewhere. Branding! 😄

Please don't take these as overly critical. I'm struggling with a patch and needed to switch my brain-gears to something else for a bit.

Looks great; keep it going!

Some first superficial thoughts

  • If the aim is to mainly attract users, I think the slideshow is good and the descriptions of the slides are also good. But I would amend some of the other texts. Take the intro text after the slide show:

The Kontact suite is the powerful PIM solution of KDE. It lets you handle email, agenda, contacts and other 'personal' data together in one place by delivering innovations to help you manage your communications more easily, organize your work faster and work together more closely, resulting in more productivity and efficiency in digital collaboration.

I would probably re-write to something like this:

Handle your email, calendar, contacts and other personal data with Kontact. Kontact groups everything together in one place and helps you manage your communications, organize your day and work with your colleagues. Become more productive with Kontact.

To get rid of the acronyms and jargon.

  • The "For Users" page could probably do with a FAQ. The top question I predict would be something like: "Can I migrate my stuff from y current groupware client?". That, at least, would be my main concern when considering changing to Kontact.

Looks pretty good already! Here are some things that I'd change:

  • Make the line spacing in the slideshow a bit tighter such that there are clear groups of text


My proposal:

  • The Kontact subpage feels a bit empty compared to the other ones
  • Features should be short and to the point, consider marking the important parts bold (such as with the KOrganizer page)
  • KNotes is currently a second-class citizen (not mentioned on the front page, does not have a screenshot on the page), is that by design?

Thanks for the first feedback, much appreciated!

I'll play around with some of the visuals as you suggested and shorten the leading text. Should I maybe replace it with our Vision statement? It's not shorter or fancier, but, well, it's our vision, probably should be somewhere on the page :)

Regarding the Feature pages, I was wondering if instead of the boring bullet points we should only pick a few really major features and lead with them, including screenshots (I quite like the Thunderbird Feature page in this respect) and then just list the remaining less-prominent features below either as a paragraph of text, or just like we have now on the KOrganizer page. Regarding the Kontact page there, it a bit tricky to write about Kontact, as Kontact itself cannot do anything except for showing all the parts in a single window, the actual functionality belongs to the respective components (kmail, korganizer, ...). Maybe we could focus on some overall overview of Kontact there? I think I could rename the "Products" menu to "Kontact" and only list the components in the submenu with the Kontact page having an overview of the most killer features from each component.

Regarding KNotes, yes, it is sort of a second-class citizen, it's really only listed in the menu for completeness. The main page is also missing KAddressbook, which I should add - although coming up with a short paragraph on an addressbook app is hard. I already struggled with how to describe Akregator there :)

@sharvey the screenshots already have the shadow backdrop from KWin, weird that you don't see them on the page. I'll check the Kontact icon (I can see it in the menu, could be something on my server not serving the image properly).

A couple more random ideas:

  • I think this...

Regarding the Feature pages, I was wondering if instead of the boring bullet points we should only pick a few really major features and lead with them, including screenshots

... is a very good idea. I was going to ask about what makes the Kontact suite different from the rest. Talking about what makes a product different from the competition is an age-old technique. If users are not given clear reasons to change from their current solution, they will not be inclined to change. It may be a a good moment to brainstorm said differences. I have only used Kontact for years so I am not really aware of what features and advantages it has over, say, Outlook (probably the most direct competitor) or Thunderbird. I guess I could compare it to Gmail/Calendar/etc...

  1. The obvious: It is open source, which means that (a) it is free as in speech and as in beer and (b) it is designed to protect your privacy: no sneaky-leaky closed source code syphoning off your private emails to data-hoarding corporations, the NSA, or data-stealing mafias.
  2. Kontact can easily handle all your email, be it from GMail, work or personal accounts in one clear and flexible application.
  3. Combine calendars and contact lists without having to merge them: you can see how your overall week is going to be like, showing your business meetings, dentist appointments, and flights for your holidays; or you can filter out and concentrate on one set of tasks and activities at a time, say, only work, or family, or chores.
  4. Share with your colleagues, set up meetings, etc. (expand this)
  5. Super feature-rich: (list of features, like GPG integration, the cool QR feature in the contact lists, etc... (expand this)
  6. Compatible with all major email and groupware services (no need to change the back end or provider -- important for businesses)

I know some of the above are common to many other groupware programs, but many users are unaware of all the features even in the solutions they are using right now.

  • It is good that you have a screenshot on each individual component page, but maybe it should be expandable when you click on it. Like that, users will be able to get a clearer look at what they should expect to see and it will make them feel more secure when they are trying Kontact out.
dvratil added a subscriber: vkrause.EditedJul 31 2018, 9:04 PM

Hi all,

sorry for the long delay. I've revamped the main menu - it now says "Kontact" instead of "Prodcuts" and features submenu for Kontact itself as well as the individual components, but it will likely need some input from VDG (T9299). @vkrause has kindly written up some nice content for the KMail page, I've slightly improved KOrganizer and KAddressbook (trying to be less techy) and tried to summarize Kontact.

Let me know what you think.

One thing, can you take a look at this?: T9122

We are asking projects with independent websites to include some branding for KDE. We have reached a consensus on the wording ("Made by KDE"), what it should look like ("Made by KDE" + KDE logo linked to kde.org), and it's location (in the top menu, on the right hand side). Can you work that into your re-design?

I took a second at the site (which looks great already, props to you!) and wanted to share a few things that I'd change:

  • The slide for KAdressbook has a typo (easilly instead of easily)
  • The Akregator slide does not correspond to one of the blocks at the bottom of the slide show (this is more of a VDG thing, but I just noticed it)
  • The Kontact slide text is IMHO a bit boring. The other slides always show a direct benefit of using the application, so I think we should do this here too. An alternative would be "Handle all your email, calendar and contacts within a single window", loosely taken from the text in the blue box.
  • Include a screenshot on the Kontact subpage

I also tried to rearrange two of the info texts on the front page to be more attractive for end users, but take all of those as a suggestion and not as a definitive, best way to do it.

Kontact text

Kontact unifies all our PIM applications into a single window to give you the best possible experience and boost your productivity. With Kontact you can use all the tools of our powerful suite in one place. Unlike proprietary web applications we value your privacy and support open standards, which is why Kontact gives you full control over your data. You can of course also access your data offline if you want to.

KMail text

KMail is a state-of-the-art email client that integrates well with widely use email providers like GMail. It provides many tools and features to maximize your productivity and makes working with large email accounts easy and fast. KMail supports a large variety of email protocols - POP3, IMAP, Microsoft Exchange (EWS) and more.

Thanks for the feedback, @xyquadrat - I updated the texts as you suggested.

I just don't understand the point about Akregator slide not corresponding to the blocks - there is a block about Akregator on the title page (maybe I added it after you checked). Or were you referring to something else?

Ah, I knew that I was not clear enough with this description... The slide show has those fancy blocks at the bottom where you can click to reach another slide easily:

But when you are at the Akregator slide, there is no corresponding block that lights up (probably because there are five slides but only four blocks):

I hope that the problem is clear now & thanks for your work.

There's a minor typo in the drop down "Kontact" menu on the top bar, Akregator is misspelled as Akreagtor.

Also, it would be a good idea to add links to the corresponding pages under the "Not a programmer?" section on the "Get Involved" page.

Great job on this website btw, kudos to all involved.

Thanks for your feedback guys. All issues raised should be solved now :)

dvratil added a comment.EditedSep 22 2018, 9:32 AM

Thank you all again for your help with the website.

The website is live now (it went a bit faster than I expected :-D ) on kontact.kde.org and | kontact.org. Could you please help us and spread the link on the social networks?

Edit: please only use https://kontact.kde.org , because https://kontact.org throws a certificate error right now, kontact.kde.org works correctly. (fixed)

It would be good to link to https://kontact.kde.org/ from https://www.kde.org/products/ but I can't work out a good place to do it currently

dvratil added a comment.EditedSep 24 2018, 11:16 AM

That would be nice, yes. But I don't think that Kontact is any more special than e.g. Krita, Digikam, KDevelop etc. to have its own entry on the Products webpage.

Maybe a second row with links to websites of those projects and a "More ...." link to the https://www.kde.org/applications page?

Edit: a bit offtopic, but shouldn't that page also list Frameworks? That's certainly one of our most important products...

skadinna closed this task as Resolved.Nov 29 2018, 4:04 PM