New dependency for kpat (required for CI)
Closed, ResolvedPublic

Description

Hi,

recently, kpat gained a new hard dependency on freecell-solver (http://fc-solve.shlomifish.org/). As that library is currently not installed on the CI server, we get a build failure (https://build.kde.org/job/Applications%20kpat%20kf5-qt5%20SUSEQt5.9/19/console). Would it be possible to add the library to the CI system?

Cheers,
Fabian

fabiank created this task.May 22 2018, 7:47 PM
Restricted Application added a subscriber: sysadmin. · View Herald TranscriptMay 22 2018, 7:47 PM
bcooksley edited projects, added build.kde.org; removed Sysadmin.May 23 2018, 8:14 AM
bcooksley added subscribers: lbeltrame, fvogt, adridg and 2 others.

Hi Fabian,

As we've outlined previously around 2 weeks notice should be given so we can arrange for dependencies to be made available.

@lbeltrame and @fvogt - I couldn't find a package in SUSE for this, is this something which has yet to be packaged on your side?
@tcberner and @adridg - could you please take care of the FreeBSD side of things?

bcooksley changed the visibility from "Custom Policy" to "Public (No Login Required)".May 23 2018, 8:14 AM
bcooksley changed the edit policy from "Custom Policy" to "All Users".

Yes, that will need to get packaged. We'll keep you posted.

Sure, I'll add it later

Done

kpat still needs to add the required library paths or use the pkgconfig target:

12:25:27 /usr/bin/ld: error: unable to find library -lfreecell-solver

mfg Tobias

Thanks for the quick responses Luca and Tobias.

FTR, it's not ready yet for openSUSE, the package doesn't pass the rpmlint check due to missing return in a couple places.

E: freecell-solver no-return-in-nonvoid-function /home/abuild/rpmbuild/BUILD/freecell-solver-4.18.0/lib.c:1632, 1613, 4548

Afaics, the issue is still in the git repo.

@cgiboudeaux : please see the patch in this commit - https://github.com/shlomif/fc-solve/commit/9a2917edf0d13bbefef82a39b896ef14f62da876 - i was aware of these warnings, but ignored them because the fix made performance suffer a little.

@cgiboudeaux : please see the patch in this commit - https://github.com/shlomif/fc-solve/commit/9a2917edf0d13bbefef82a39b896ef14f62da876 - i was aware of these warnings, but ignored them because the fix made performance suffer a little.

If fixed correctly, there is exactly 0 difference in the compiler output.

Either your code had undefined behaviour (which is very bad) or you can add a __builtin_unreachable() or abort() in those places.

@cgiboudeaux : please see the patch in this commit - https://github.com/shlomif/fc-solve/commit/9a2917edf0d13bbefef82a39b896ef14f62da876 - i was aware of these warnings, but ignored them because the fix made performance suffer a little.

Thanks, I adapted the patch for the 4.18.0 release and submitted it.

Status update: freecell-solver-devel can be added to the openSUSE docker files.

bcooksley closed this task as Resolved.May 31 2018, 10:32 AM
bcooksley claimed this task.

This has now been applied to the CI system.

Given the substantial amount of time since we last rebuilt the images i've treated this as an ABI breaking event and have triggered a rebuild of all Dependency Build jobs for the SUSEQt5.9 and SUSEQt5.10 platforms.

Well, thanks everyone for adding the required libraries, and sorry @bcooksley for not giving notice in advance.