all software needs to be > ubuntu
Closed, ResolvedPublic

Description

https://build.neon.kde.org/view/mgmt/job/mgmt_repo_test_versions_unstable_bionic/

(and other tests)

MUST ABSOLUTELY have a greater version than ubuntu to ensure upgrades go to our versions, not ubuntus, specifically we may have crucial changes (such as in base-files) which must be applied for the upgrade and the reboot to succeed properly as a "neon" system rather than an "ubuntu" system.

Additionaly it may be worth considering to establish a pin on neon before the upgrade and remove it on first boot afterwards to prevent transient version lagging from affecting upgrades a month or two down the line.

sitter created this task.May 16 2018, 12:23 PM
sitter triaged this task as Normal priority.
sitter moved this task from Later to Backlog on the KDE Neon : bionic board.Jun 21 2018, 10:37 AM
sitter lowered the priority of this task from Normal to Low.Jul 3 2018, 11:37 AM
sitter moved this task from Backlog to Later on the KDE Neon : bionic board.

This is now clean for all 4 build permutations.

Needs looking over again when release is around the corner.

jriddell moved this task from Later to Backlog on the KDE Neon : bionic board.Oct 3 2018, 8:39 AM
jriddell moved this task from Backlog to Doing on the KDE Neon : bionic board.
jriddell claimed this task.
sitter closed this task as Resolved.Feb 12 2019, 1:49 PM

Let's close it, I am guessing this is a non-issue given there were no reports to the contrary