Dummy download icons in Firefox - 18.04 release
Open, Needs TriagePublic

Description

(Unlike Neon), Kubuntu has dummy download icons in Firefox.

Perhaps it's fixable?

I'm expecting invalidation, of course. Bureaucracy is what I hate most.

I'm expecting invalidation, of course. Bureaucracy is what I hate most.

Don't be passive aggressive. Please learn to communicate professionally or else go away.

Back to the issue: are you saying that with a clean install of Kubuntu 18.04, Firebox's downloads menu already has two items for Neon ISOs in it?

If you would like to continue reporting bugs, I will ask you to first read and understand https://community.kde.org/Get_Involved/Bug_Reporting.

Don't be passive aggressive. Please learn to communicate professionally or else go away.

Fair point.

Back to the issue: are you saying that with a clean install of Kubuntu 18.04, Firebox's downloads menu already has two items for Neon ISOs in it?

No. I mean the download icons look sorta like that

in Neon.

The icons representing the items that are being downloaded, whether iso, sig, ...

Do you think it would help to have a picture from Neon, or you already know what I mean?

Yes, that helps. I can confirm this in Bionic. This works properly in Artful with the same version of Firefox and Plasma (provided by backports).

Okay. Then I'll try to make this one "actionable" :)

Now the question is: is this a Kubuntu issue or an Ubuntu issue? Can you reproduce the issue with a fresh install of regular old Ubuntu 18.04 too? If so, it should be reported on launchpad. If not, it can stay here.

Neon User

Proof: the scrollbar :)

Now the question is: is this a Kubuntu issue or an Ubuntu issue? Can you reproduce the issue with a fresh install of regular old Ubuntu 18.04 too? If so, it should be reported on launchpad. If not, it can stay here.

I don't know.

Now the question is: is this a Kubuntu issue or an Ubuntu issue? Can you reproduce the issue with a fresh install of regular old Ubuntu 18.04 too? If so, it should be reported on launchpad. If not, it can stay here.

I don't know.

I told you how to find out:

Can you reproduce the issue with a fresh install of regular old Ubuntu 18.04 too?

See https://community.kde.org/Get_Involved/Bug_Reporting#Bug_reporting_involves_responsibility

This comment was removed by raddison.
This comment was removed by raddison.

I've only got some talent at pinpointing flaws. Call me that extra pair of eyes. I've got no calling for this kinda stuff. But I can surely appreciate a good OS. Has anyone told you about this Firefox thing? Well, I have. I'm sorry that's it only so much I can do at the moment but is better than nothing, I guess.

Yes, that helps. I can confirm this in Bionic. This works properly in Artful with the same version of Firefox and Plasma (provided by backports).

Good. Then me coming here wasn't futile.

Can you reproduce the issue with a fresh install of regular old Ubuntu 18.04 too?

Can I use a flavor instead of flagship ubuntu in order to get to the bottom of this?

Ubuntu flagship 18.04

https://youtu.be/YQenqXSoc4s?t=37


Mint 19, based on 18.04

https://youtu.be/OdC76OWG-u8?t=56


Kubuntu 18.04

https://youtu.be/tcLtLH32JUU?t=46

@rikmills Could you, please, fix this? Thank you very much in advance.

raddison moved this task from Inbox to Packaging / Devel on the Kubuntu board.Mon, Jul 2, 9:46 AM

Now the question is: is this a Kubuntu issue or an Ubuntu issue? Can you reproduce the issue with a fresh install of regular old Ubuntu 18.04 too? If so, it should be reported on launchpad. If not, it can stay here.

@ngraham I think sufficient evidence has been gathered. This is a Kubuntu issue. Where do we go from here?

Thanks! Now we investigate the issue and try to find a fix. :)

FWIW, I don't see the issue in my Bionic install.

Thank you, Nathan. It should be fixed asap.

Thanks! Now we investigate the issue and try to find a fix. :)

Any news?