Define and communicate set of "blocking" modules
Open, HighPublic

Description

That is, all modules that need to be ported before we can remove deprecated/obsolete functions or modules.

The currently proposed set would be:

  • Plasma
  • KDE Applications
  • Extragear
  • Calligra

Not included would be playground.

vkrause created this task.Sep 10 2019, 7:47 AM
vkrause triaged this task as High priority.

Kopete looks like a particularly painful one, currently part of applications.

Based on T11567 khotkeys can be excluded from the list.

Rekonq (in extragear) might be another candidate for exclusion from the list, master is still Qt4.

For me all Qt4 apps must be exclude from list. If in 7 years nobody ported them to Qt5, nobody will work for qt6

For me all Qt4 apps must be exclude from list. If in 7 years nobody ported them to Qt5, nobody will work for qt6

Yeah, that seems reasonable to me as well.

rekonq moved to unmaintained, so that's not longer a problem