Testing day
Open, HighPublic

Description

Please comment here any bug you find.

afarid created this task.Feb 21 2019, 6:08 PM
afarid triaged this task as High priority.
emohr added a subscriber: emohr.EditedFeb 22 2019, 4:19 PM

Equaliz0r and G -> no settings -> We might however hide the arrow on such effects because it is confusing.

emohr added a comment.Feb 22 2019, 4:21 PM

After draggingit down the timeline, hovering over it causes the timeline to jump up again. -> we should implement a "test/checker" to avoid that.

emohr added a comment.Feb 22 2019, 4:23 PM

Feature request: Title -> anitmating text position/size would be nice

> Equaliz0r and G -> no settings -> We might however hide the arrow on such effects because it is confusing.

Done
https://cgit.kde.org/kdenlive.git/commit/?h=refactoring_timeline&id=90f146d555eb684f251359d6626075c6732464d0

emohr added a comment.EditedFeb 22 2019, 5:19 PM

proxy clips show up as MKV -> has to be checked why

resolved by this commit.

https://cgit.kde.org/kdenlive.git/commit/?h=refactoring_timeline&id=5f775d909c7e28b9eb0cd82508da5adc68571d5d

emohr added a comment.Feb 22 2019, 5:33 PM

check the Youtube video to grab bugs still with refactoring: https://www.youtube.com/watch?v=LZ34zSR-6Ys&lc=UgxbQa6hWZrgDzL6qnR4AaABAg

  • automatic compositions from old projects lose automatic feature
  • Cursor getting out of view on pressing end on large zoom
  • Don't scale video thumbs with zoom
emohr added a comment.EditedFeb 22 2019, 7:25 PM

that unearths another bug: the existing project has an image clip in project 1920x1080 resolution with an "alpha opertions" effect on it.
It was originally set to operation: blur, threshold: 500, and amount: 3.
in refactoring it is set to operation: noop, threshold: 1000, and amount: 1000.
image clip is svg

another observation on the buggy alpha ops: disabling the clip effect, then reenabling it brings back the correct effect settings

emohr added a comment.Feb 22 2019, 7:33 PM
  • automatic compositions from old projects lose automatic feature

transition is "composite and transform" on V6 from an svg image clip onto V5 below with another svg image clip; "composition track" is set to automatic, but doesn't work unless changed and then changed back

the c&t bug is even weirder: switching from "automatic" --> "background" --> "automatic" doesn't work until you do "automatic" --> "background", then reposition the timeline cursor, then "background" --> "automatic"
looks as if there is something not quite in sync

emohr added a comment.Feb 22 2019, 8:26 PM

When I let Kdenlive for 1 hour or 2 on it's own whitout working -> timeline doesn't react anymore.

kurtz added a subscriber: kurtz.Feb 23 2019, 1:33 PM

As far is i saw thers actually no option to reverse a clip. Probably you can it to the "change speed" Dialog...

emohr added a comment.EditedFeb 23 2019, 7:33 PM

As far is i saw thers actually no option to reverse a clip. Probably you can it to the "change speed" Dialog...

added in https://invent.kde.org/kde/kdenlive/issues/63

Where is speed control? how to make speed ramp now? on Motion efect I have freeze only

Where is speed control? how to make speed ramp now? on Motion efect I have freeze only

Speed control is quite broken and is being reworked on.
https://bugs.kde.org/buglist.cgi?quicksearch=kdenlive%20speed&list_id=1593894

Vincent PINON 2018-10-19 11:09:06 UTC
Hello,
We unfortunately know that, for long in "release" versions, clips with speed effect can't be edited once the effect has been applied, or the timeline synchronization gets messed :( (see many "duplicate" reports on this tracker)
The rewrite happening in "unstable" versions should allow to handle this effect correctly, but I'm not sure all features are re-enabled at this stage.