flatpak: update runtime to 18.08
Closed, ResolvedPublic

Description

Gives us access to more recent compilers and gpg 2.2.9.

  • /usr/lib/sasl2/ is gone
  • libgpg-error etc are incompatible (can be worked around by setting LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/ for gpg-agent-connect) which seems to produce some problems at least.
Failed to lookup keys:  150 Invalid crypto engine
GPG Engine check failed. 117440662
cmollekopf triaged this task as Normal priority.

Note that clang seems broken, but gcc builds everything fine.

cmollekopf closed this task as Resolved.Dec 27 2018, 10:05 PM
cmollekopf claimed this task.

I updated gpg related stuff and we're building sasl ourselves. Seems to work just fine.