Title Clip: missing fonts should not just get an empty error display
Closed, ResolvedPublic

Description

When you open a kdenlive project with titles that use a font that is not available on the platform, the Clip Problems box pops up, but doesn't actually list any information about what is wrong. There are no missing clips to resolve, and no information that a font is missing -- just this hint that something is wrong.

Beside the message it would be good to choose a substitute font as well.

Bug 401903

emohr created this task.Dec 9 2018, 4:59 PM
emohr updated the task description. (Show Details)
afarid added a subscriber: afarid.Dec 9 2018, 5:53 PM

Scribus handles this nicely in situations like this. Maybe also add an option to automatically embed fonts?

akhilkgangadharan closed this task as Resolved.Jan 7 2019, 11:52 AM
akhilkgangadharan claimed this task.

I reproduced this bug on my Kdenlive (refactoring_branch) and it looks like it is already handled - the Clips Problems pops up with the necessary information with a font automatically being used in place :

Yes, thanks for pointing this. I just backported the fix to the stable 18.12 branch

emohr added a comment.Jan 7 2019, 4:54 PM

Akhil, JBM: As I understand we can close Bug 401903. Correct?

Yes emohr, we can.